The 'display' attribute returns false

Fixed, flighted Issue #10022185

Details

Author
Nick L.
Created
Dec 1, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
14.14393
Fixed in build #
15052
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

We have one table element is display on IE and Edge. Please see the attachments Edge and IE11 screenshots.
Its display attribute is true on IEDriver. Please see attachment IEdriver test screenshot.
But Its display attribute is false on EdgeDriver. Please see attachment EdgeDrivertest screenshot.

It is a edgeDriver bug.

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Ibrahim O.”

  • Thank you for the feedback. I get “true” value on my end. Could you please provide your HTML and webdriver code? 

    Best regards,
    The MS Edge Team 

  • Thanks you for your help. Here is the webdriver code. please reference it.

    Code:
    EdgeOptions eopt = new EdgeOptions();
    IWebDriver _CurrentDriver = new EdgeDriver(eopt);
    _CurrentDriver.Navigate().GoToUrl(“html path”);
    _CurrentDriver.Manage().Window.Maximize();
    IWebElement obj = CurrentDriver.FindElement(By.Id("ctl00_WebPartManager_CM_InstanceHeader_WP" + flyoutName + “_CollapsableSectionExTable”));

    obj.Displayed //Check the Displayed is true or false on IE11 and Edge.

    And I have add the test Html on attachment. Please see the Test.7z

    Thanks~
    Nick L.

  • Update the webdriver code:

    EdgeOptions eopt = new EdgeOptions();
    IWebDriver _CurrentDriver = new EdgeDriver(eopt);
    _CurrentDriver.Navigate().GoToUrl(“html path”); //Please change the html path to your actual path.
    _CurrentDriver.Manage().Window.Maximize();
    IWebElement obj = CurrentDriver.FindElement(By.Id("ctl00_WebPartManager_CM_InstanceHeader_WP_Content_CollapsableSectionExTable”));
    obj.Displayed //Check the Displayed is true or false on IE11 and Edge.

    Thanks~
    Nick L.

  • Appreciate the update, I see the issue now. I will escalate this for further processing. Thanks again for your assistance in the investigation.

    All the best,
    The MS Edge Team 

  • Microsoft Edge Team

    Changed Assigned To to “Mara P.”

    Changed Assigned To from “Mara P.” to “Navin A.”

    Changed Status to “Confirmed”

    Changed Title from “Attribute ‘display’ is issue from web element with EdgeWebDriver 14393.” to “The 'display' attribute returns false”

    Changed Status from “Confirmed” to “Fixed, not yet flighted”

    Changed Status from “Fixed, not yet flighted” to “Fixed, flighted”

    Changed Status from “Fixed, flighted” to “Fixed, not yet flighted”

    Changed Status from “Fixed, not yet flighted” to “Fixed, flighted”

You need to sign in to your Microsoft account to add a comment.

Sign in