SVG filter BackgroundImage without enable-background causes rendering to fail completely

Won’t fix Issue #100949

Details

Created
Apr 27, 2014
Privacy
This issue is public.
Found in build #
0.0010
Reports
Reported by 0 people

Sign in to watch or report this issue.

Steps to reproduce

URL = N/A

URL:
Always Happens

REPRO STEPS:
Five stripes, including some applications of multiply blend mode filter. Try the file in Opera to see the correct rendering.

EXPECTED RESULTS:
IE rendering freezes after drawing the green stripe, at the point where it sees the first BackgroundImage reference. Rendering becomes frozen. If the image is embedded in a page, the whole page stops rendering.

As a secondary issue, IE incorrectly fails to see the enable-background declaration in the main SVG node. Please note that sorting this part of the issue alone is not enough to close the problem, as IE would remain vulnerable to malicious SVG that chooses not to declare enable-background on purpose.

ACTUAL RESULTS:

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Kevin B.”

      Changed Assigned To from “Kevin B.” to “Bogdan B.”

      Changed Assigned To from “Bogdan B.” to “Kevin B.”

      Changed Status to “Confirmed”

      Changed Assigned To from “Kevin B.” to “IPBS P.”

      Changed Status from “Confirmed” to “Won’t fix”

      Changed Assigned To from “IPBS P.” to “Rossen A.”

      Changed Assigned To to “Bogdan B.”

      Changed Status from “Won’t fix”

      Changed Assigned To from “Bogdan B.” to “IPBS P.”

      Changed Status to “Won’t fix”

    You need to sign in to your Microsoft account to add a comment.

    Sign in