Autofocus attribute effectively does not work

Fixed Issue #101198

Details

Created
Apr 27, 2014
Privacy
This issue is public.
Found in build #
0.0010
Reports
Reported by 0 people

Sign in to watch or report this issue.

Steps to reproduce

URL = http://tanalin.com/_experimentz/bugs/ie/2013/autofocus

URL:
Always Happens

REPRO STEPS:
The INPUT element having autofocus attribute should be focused automatically, and the user should be able to enter text into it once page is loaded.

EXPECTED RESULTS:
Autofocusing does not work on first page load. Autofocusing works only after reloading the page (either by pressing F5 key, or by clicking Refresh button, or by focusing location bar and pressing Enter again), so effectively autofocus does not work at all.

ACTUAL RESULTS:
 

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Rossen A.”

      Changed Assigned To from “Rossen A.” to “Greg P.”

      Changed Steps to Reproduce

      Changed Status to “In code review”

      Changed Status from “In code review” to “In progress”

      Changed Status from “In progress” to “In code review”

      Changed Status from “In code review” to “In progress”

      Changed Assigned To from “Greg P.” to “IPBS P.”

      Changed Status from “In progress” to “Fixed”

      Changed Assigned To from “IPBS P.” to “Christian F.”

      Changed Steps to Reproduce

    • This still happens if the input is of type range. Example. http://plntxt.com/auto-focus-nocus

    • I should have included - Microsoft Edge 38.14393.0.0, Microsoft EdgeHtml 14.14393

    You need to sign in to your Microsoft account to add a comment.

    Sign in