Tables with position:absolute are rendered wrong coordinates

Fixed, not yet flighted Issue #102499

Details

Created
Apr 27, 2014
Privacy
This issue is public.
Found in build #
0.0010
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

URL = http://jsfiddle.net/SYhDr/11/

URL:
http://jsfiddle.net/SYhDr/11/

REPRO STEPS:

  1. Launch IE
  2. Navigate to http://jsfiddle.net/SYhDr/11/
  3. Observe the result pane with 2 tables and 1 div absolutely positioned in the gray container.

EXPECTED RESULTS:
Both absolutely positioned tables should have the same height (equal to the height of the div) and be placed in one place (their top border should touch the top edge of the container, and the right border should be 5 pixels right to the right edge of the container, like the right border of the div).

ACTUAL RESULTS:
The table that has top: 0 (with no units) is not as tall as the table that has top: 0%, it has the height of its content. Both tables cross the right edge of the container. It seems that not their right border, but the right edge of their content is aligned at 5px to the right edge of the container.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Kevin B.”

      Changed Steps to Reproduce

      Changed Status to “Confirmed”

      Changed Status from “Confirmed” to “In progress”

      Changed Assigned To from “Kevin B.” to “Saqib A.”

      Changed Status from “In progress” to “In code review”

      Changed Status from “In code review” to “In progress”

      Changed Status from “In progress” to “In code review”

      Changed Status from “In code review” to “In progress”

      Changed Assigned To from “Saqib A.” to “IPBS P.”

      Changed Status from “In progress” to “Fixed”

      Changed Status from “Fixed” to “Fixed, not yet flighted”

      Changed Assigned To from “IPBS P.” to “Rossen A.”

      Changed Steps to Reproduce

    • I see this issue marked as fixed, It may have been in Edge but it isn’t in IE11.0.9600.18499

      In the process of checking if it was an IE bug I made another fiddle that highlights this same issue: https://jsfiddle.net/mugwc4Lq/4/

    You need to sign in to your Microsoft account to add a comment.

    Sign in