Can't access any Google sites in Edge and IE11 after install 14986 (on 21.12.2016) of Windows 10 Insider Preview

Fixed Issue #10311428

Details

Author
Angel T.
Created
Dec 25, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
  • Internet Explorer
Found in build #
14.14986
Reports
Reported by 77 people

Sign in to watch or report this issue.

Steps to reproduce

Can’t load Google Search, YouTube, Maps, Finance, etc.
Works only in InPrivate browsing!!!
Delete the history, reset the IE settings, tried the TCP Fast Open fix, disable firewall, remove any extension but still didn’t work.

Attachments

0 attachments

    Comments and activity

    • I have the same problem.

    • +1

    • How many discharges will follow after this tremendous bug- to block world Top web sites???

    • Some small progress: uncheck “Use TLS 1.2” to be able to load youtube.com

    • I want resignations!!!

    • I think this issue comes with Google, because Windows 10 Mobile Edge and other Youtube Client apps not working too.

    • I’m having the same problem.

    • nothing with sfc /scannow.

    • The problem is not related to Google, Youtube worked all the time for me, but masseffect.com does not. After I erased all stored session information yesterday, Google is up again, but masseffect.com is not. I also found out that the issue does not happen in private mode of edge.

    • Microsoft Edge Team

      Changed Assigned To to “Brad E.”

    • Can not open any Google products such as google.com, Gmail, Youtube, etc… after build 14986 was installed.  Rolled back to prior build and was good to go. Installed build 14986 again and same problem.

    • C’mon Microsoft, give us some scoop on this issue… I experience with the steps to reproduce and would like add one nuance.

      If I have Fiddler 4 running with capture just https traffic on, then again google sites work for most part. Not sure if this info helps the devs are not.

      Dear Microsoft, at least post some initial analysis as I hate using chrome and giving data access to Google.

    • +1

    • Microsoft Edge Team

      Changed Assigned To to “Balaji B.”

    • The problem is far more serious than clean cache/history/reset/TCP Fast Open fix/disable defender-firewall-extensions or other bullshit!!!
      The only way for now to load youtube/docs/plus/account/play/gmail/drive/photos is to uncheck “Use TLS 1.2”.
      But you can’t load search/maps/finance/translate/calendar. For example, in other sites like docs.unrealengine.com you can’t search!!!

      Testers of 14986- are you even run this “great” and “biggest” f…g update before make it public???
      Where is the positive point of the biggest update when it broke/destruct your BASIC and GROUND functionality???
      I am crying when my love company loosing users because of similar “right” decisions of fat out-of-reality "gods and fliers".
      Immediately all top managers must be shoot out of the company- they obviously work for the competitors, these fat hogs …
      I want resignations, immediately and big time resignations for those guys who destroying my love company!!!
      This is biggest, Biggest, BIGGEST and TREMENDOS failure ever.

      So my brothers, just on time for Christmas and Holidays Microsoft f…k us all- IE11 or Edge CAN"T load world top most popular sites like Google …
      hAPPY nEW yEAR

    • It seems we have a problem with our testing process when such a large bug is allowed to get this far in the testing procedure. This should have been caught a lot sooner before it affected so many users and with such a large impact.

    • This bug is reported from some users in the beginning of December. By my opinion, this bug will continue to live at least to 10-15-20 January.
      So TWO F…G months will be CATASTROHIC.
      Conclusion:
      Only immediately and big time resignations will prevent the start of the end for IE and Edge and Inisder Preview and then to Microsoft … simple math …

    • Anyone find a real solution for this?

    • Disabling (unchecking) TLS 1.2 worked for me. goo.gl/O4bALU

    • Another huge problem is very rare crashing while watching some youtube, and only restart is helping!!!- neither IE11 or Edge can load youtube or other html5 video, only Chrome/Firefox.
      This update is absolute f…g s…t, TREMENDOS s…t!!!

    • The same issue over here in the Dutch version.
      Edge is not working at all, and IE11 does not open Google sites.
      Had to uncheck TLS 1.2 in properties to open www.google.com

      I’am using Firefox from now, but how can I tell it my customers?

    • Similar. disabling TLS 1.2 doesn’t help. Both my IE11 and Edge browsers are not able to load any google websites but those websites work just fine on Chrome and Firefox. Also, IE11 will work OK if I run it in “inPrivate” mode. I tried just about everything; cleared all the histories; disabled all the add-ins, etc. I yield to Microsoft to find the answer.

    • Same problem here. Looks like I can access any site but the google.com root/search site.
      A sites like https://translate.google.com/ works just fine.

    • I can’t open google finance direct, but I can if type in one tab first translate.google.com and then google.com/finance.
      What the f…k.???

    • It’s an issue with the build which will probably get fixed in the next build. Meanwhile, as a workaround you can either access Google via InPrivate browsing or add Google DNS entries to your Ethernet or WiFi adapter’s IPv4 properties.

    • Google.com not work with Google DNS!!! Only in InPrivate.
      With DNS work google finance

    • Thanks Tim!
      I can confirm the InPrivate browsing work around.

    • Same issue here with me.
      I’ve reset the winsock stack, tried every combination of settings I can think, cleared every cache, etc etc etc.
      Google sites simply will not open up in IE11 or Edge on Build 14986 unless I use InPrivate browsing. It’s obviously something credential/account related SOMEHOW.
      But seriously, MS… dafuq, guys?

    • Microsoft Edge Team

      Changed Status to “Not reproducible”

    • How can this issue be marked "Not reproducible"?!

      To easy! Judging on the number comments confirming the problem this is a real issue and most certainly reproducible on multiple machines. (Hint: see feedback on the current Insider Fast build 14986 of Windows 10 confirming this issue)

    • Theo, this “Not reproducible” only approve on 100%that it is time for big time resignations and shoot out of the company for most fattest managers

    • Marking this as non-reproducable is the height of laziness and is completely irresponsible. Find the problem. Now.

    • Thanks Microsoft. Now I have moved to Chrome since you think this is no problem.

    • Have the same issue here. Only solution i found was accessing in InPrivate mode. Otherwise, nothing worked.

    • Disabling (unchecking) TLS 1.2 worked for me also, slower load of page though.

    • Same hing for me. Also, tiles pinned to the homescreen seems to not work too, cause they use google.

    • I’m having the same issue on multiple machines. In-Private or Chrome seems to be the only workaround. The only way this issue can be “Not Reproducible” is if they don’t try! It’s 100% reproducible. One think in Microsoft’s defence is the problem on my computer tends to be slightly intermittent. I have minutes per day where the sites work but >95% of the time it is broke.

    • Microsoft have acknowledged on their blog that there’s an issue (see near bottom, 4th bullet point under ‘Known issues for PC’ section): https://blogs.windows.com/windowsexperience/2017/01/09/announcing-windows-10-insider-preview-build-15002-pc/#CLM0ixeVS9VUug2T.97

    • I updated to build 15002 and although I then had some audio and graphics issues (that I resolved by reinstalling drivers), the Google access issue seems to have gone away - I can now access all the Google URLS that I couldn’t before.

    • I think the biggest problem is because Google is showing 2 bad SOA records, putting 8.8.8.8 and 8.8.4.4 in network setting has helped with YouTube. putting 8.8.8.8 in the router has helped with Google. Still have not been able to sign in to YouTube or Google though. I think this way is better than unchecking TLS 1.2 …( BTW I am on a Dell laptop)

    • I can’t open google sites like Gmail google plus YouTube etc
      But I can open private browser
      There are no goog browser to fix this issue

    • Still happening in Edge build 39.15002.1001.0. Now it says (when connecting to google.nl):

      Can’t connect securely to this page
      This might be because the site uses outdated or unsafe TLS security settings. If this keeps happening, try contacting the website’s owner.

    • Pepijn, I got that error too - try refreshing the page or manually typing the URL, particularly without the http/https prefix to begin with. It is consistently ok for me now.

    • That’s a bug in the release (14986). It cannot be reliably fixed. The issue is gone in build 15002.rs_prerelease.170102-1700

    • Thanks for the feedback. This could have been an intermittent issue- but should not affect newer builds. If this reproduces on a newer build, please feel free to reopen.

      Thanks!

    • It’d be really helpful if issues could be updated with the build they’re fixed in. I have no idea if the build I’m on has been fixed, or if I’ll be getting the build any time soon. This applies to all issues too. Another one of mine was closed as fixed 2 months ago yet I’m still seeing the issue and have no idea if it’s been released or not.

      Microsoft Edge 39.14986.1000.0
      Microsoft EdgeHTML 15.14986

    • Strange. My PC updated to 14986 on 18 Dec 2016, but this problem with IE and Edge not being able to access google web-sites only started for me yesterday, i.e. it was working fine before then.

    • Same here - problem only started in the last 24 hours. Have been on 14986 since it was released and Google sites (incl YouTube) worked fine until a day ago. Can access them if I switch to InPrivate in Edge or IE11, but doesn’t help day to day use of a ton of other websites that access stuff hosted somewhere on Google.

    • Stroke of genius Microsoft… let’s disable the competition. But hey, guess what it works fine when I use Chrome… which I will now.

    • Same Google domain issues here. I tried using F12 tools in an undocked window to see the responses when I hit various Google sites but as soon as I hit the page the F12 window closes without warning. Not sure this is correct behaviour for a debug tool so it’s all very suspicious behaviour.

    • What fixed it for me was going to IE 11 Advanced options and unselect Use TLS 1.2 option.

      Strangely, putting it back on after successful browse and it still works.

    • edge hadn’t been working for me at all since early December. I then received a whole load of system and Firmware updates. On the 18th Jan which fixed things. But as of today Google and a handful of other sires are no longer reachable unless In Private. wired. 14986 has been crap

    • Having exactly the same issue. Certain Google domains don’t work on either IE or Edge: they give a “Can’t reach this page” error. However, certain other domains (like https://translate.google.com/) do seem to work.
      For some unselecting TLS 1.2 in Advanced Internet options seems to work - for me it didn’t.
      For some selecting a google DNS seems to work (such as 8.8.8.8 or 8.8.4.4) - for me it didn’t.
      Going to InPrivate mode is the only consistent workaround, other than using another browser such as FireFox or Chrome.
      My version: Microsoft Edge 39.14986.1000.0

    • I also have the same problem on two different computers, connected to two different internet connection… and yes, I’m on build 14986…
      last friday, everything was fine with the same build… but today, none of the google sites are working.

    • Niels v. sometimes you have to put 8.8.8.8 in your routers DNS beside having to put it in your network settings… I believe this to be a Smart Screen issue or even Windows Defender… a check on Googles DNS shows 2 bad certificates… Windows is taking this to mean the site is hi-jacked… everything seems to be working fine in Build 15014 - Microsoft Edge 39.15014.1000.0

    • +1

    • I got the same problem Too.

    • Same problem too

    • Microsoft Edge Team

      Changed Assigned To to “Colleen W.”

      Changed Status from “Not reproducible”

    • We have confirmed issues related to connecting to Google sites on Insider Preview builds and are investigating at high priority. The issue is related to a new security feature (token binding) that is being introduced in Edge and Google is one of the first sites to adopt it. In the meantime, you can use InPrivate to work around as noted in the bug repro.

      If you are seeing this on Anniversary Update (14393), please let us know.

    • Charles, THANK you! I have three PCs in slow ring at this build 14393. Anything I can do to test or hack am happy to give feedback. -Karl Fasick

    • Sorry, Charles I, my bad - I’m Version 10.0.14986.

    • Microsoft Edge Team

      Changed Status to “Site Outreach”

      Changed Status from “Site Outreach” to “Confirmed”

      Changed Status from “Confirmed” to “Site Outreach”

      Changed Status from “Site Outreach” to “Confirmed”

    • @Charles M.
      (build 14986)
      In case it helps to isolate the issue, both IE11 and Edge work fine while Fiddler 4 is capturing.

    • +1

    • Having the same issue only recently started

    • Experiencing the same issue in EDGE on WM10 build 14977 L950

    • I cant say what I think, You’ll all hate me ;)

    • Same behavior.
      WIN10 build 14986
      Google sites not accessible with Edge / IE
      Edge InPrivate browsing this sites is working.
      Firefox is working.

    • Just an update: my VPN workaround ceased working and now, Youtube is also affected. InPrivate is the only workaround remaining.

      @Charles M: I did not experience the issue on the Anniversary update, it started when upgrading to 14986. Besides, none of the machines at my workplace, which are at 14393 are affected.

    • Same problem here. Very frustrating.

    • Isn’t in google that put in some code to make you switch to Chrome? It is so strange that this is working in Private mode

    • Koenraad H. +1

    • What is being done about this problem please?

    • For me, with build 15019, it appears as though (at lease on this machine) the issue has gone away. I will try on other machines and report back if it is not consistent.

    • We are rolling out some improvements in the next Insider flight (15025+) and look forward to your feedback. For those interested, this is related to token binding which is a new security feature that is being worked on by both Microsoft and Google: http://www.ietf.org/proceedings/91/slides/slides-91-uta-2.pdf.

    • Thanks Charles. For those of us on the slow ring, any idea of when an update would come that will fix this please?

    • I’m seriously starting to doubt Microsoft’s validation process before rolling out these updates. Definitely opting out of these pre-releases!

    • Thanks Charles. It’s good to see concrete information has now been provided - especially on https://blogs.windows.com/windowsexperience/2017/01/27/announcing-windows-10-insider-preview-build-15019-pc/#LvYmd8jWBvIzoI0Z.97
      What I don’t understand is that if this feature is being worked on by Microsoft and Google, wouldn’t it make more sense and be more appropriate if Microsoft and Google implemented changes to and tested token binding in their own internal development environments instead of rolling out changes to affect the general public?

    • You would think that MS would stop this build from being pushed to its customers… This is poor software dev. if you ask me.

    • seriously guys, stop complaining… this is pre release software… when you install the insider build, it tells you that you might have bugs.
      if you’re not happy, go on back on the stable release.

    • Mario, if its a known bug you fix it, with a patch or pull the build. I don’t know why that’s such an issue.

    • Jeff, sorry I don’t have a timeline on the next Slow release. You could move to fast temporarily then revert to slow if this bug is blocking you.

      Tim, we both do a lot of internal testing but difficult to catch everything when code is moving quickly on both sides. Remember that Fast builds are just a few days old so some instability should be expected :)

    • Jason, go on the fast release cycle and it’s fixed… simple as that.

    • @Mario G, your comment is a fair one and good point (btw I’m not complaining :) - this is what I frequently say to the wife! But for a complex change like this that two software companies are working together to implement, IMHO it makes more sense that they would work on these things together, internally, prior to releasing implemented changes with possible/expected bugs to insiders. At a minimum there needs to be better acknowledgement of issues, information and communication from MS. 

      Anyway I think this Google access issue can be put to rest given MS have acknowledge the issue, communicated what they’re doing and why they’re doing it.

    • No complaining here either, but, like Tim M. said, acknowledgement would suffice, and would have saved me lost of frustration. Better than that, an option to turn the new experimental feature on/off would be awesome.

    • Microsoft Edge Team

      Changed Status from “Confirmed” to “Fixed”

    • Fix is out in latest Insider Fast build (15025). Please update and let us know if any of you are still seeing issues.

    • Still have problem up to today. Tried to download latest 15025 etc but won’t download Pro 4. Just gives me error. Restarted. Same.

    • Installing 15025 not fixed issue. Can’t access to Google Webmaster tools

    • It worked for me. Build 15025 removed the problem completely. All Google sites accesible now. Thanks!

    • 15025 works well for me.

    • MS please. it’s not fixed. Not having trouble to access all other Google sites such as analytics, finances, youtube but Adwords and Search Console websites access is blocked. 
      ScreenSketch

    • “Mario G.” it is not about complaining. If you want to be better and to create better product crucial is to NOT release such tremendous BUG. Simple as that. Otherwise your users will gone …
      I repeat- how many resignations rise after this tremendous failure???

      P.S.
      Any update after 14986 fix the problem including the last update- 15025

    • I moved to fast ring and got it fixed 🙂
      However, I had to turn smart scan off and back on again, and then reload affected pages.
      From my perspective, that process needs to be removed to mark the issue as complete.

    • Same problem here (14986 by slow ring); I’m moving to the fast ring. Thx.

    • After downloading 15025 all fixed! Woohoo! Thank god, without Google sites I feel lost sometimes. Back to normal.

    • Skype preview won’t work or download though, not sure it’s related.

    • I stopped using Edge. I’m on Chrome now. It works in 14986.

    • I’m on the slow ring. I’m surprised that MS let this build out on the slow ring with such an obvious bug. What’s the point of being in the slow ring if MS aren’t going to fix the issues before they release it?

    • I got along with Chrome for Google sites. I REALLY like Edge for the pen functionality. Fortunately moving on to the Fast Ring has fixed the issue with their latest build BUT at the expense of sliwer boot times. The good news is that there’s a fix coming down the line :-)

    • Why is this marked 'Fixed’. It most certainly is NOT fixed.

    • The change to fast ring (and downloading the latest version) fixed it for me. There has to be a better way of finding the solutions. It is not acceptable to put ‘Fixed’ at the top of the feed without a link to the 'fix’. The ‘fix’ should be a Windows update NOT changing from slow ring to fast ring.
      If the real issue is that Google have not implemented the agreed changes to the joint MS/Google protocol pressure should have been put on Google to implement the changes

    • I guess the issue IS fixed, just not in 14986. So technically it’s correct, but very misleading. They may not be able to roll out this individual build to 14986. MS are very quiet on major (or any) issues and it would be good to see more comment from them. Of course these are Tech Previews so bugs are to be expected.

    • You get a problem like this. You try everything you know to fix it. You get grumpy. You search the web for people having the same problem - in itself frustrating as people suggest trivia like check your connection. You get more grumpy. Finally you find this webpage and realise you’re not alone. They even tell you what you already know – using In-Private browsing solves it. You’re happier. You even find Microsoft has heard us and has fixed it. You get a little buzz of satisfaction about the power of crowd-sourced bug crunching. And you feel better again. And you fall in love with Microsoft all over again. Isn’t life wonderful.

    • Это просто пиздец. Прошло 2 месяца, а главный поисковый и медийный ресурс открывается только сторонним браузером или через private mode. Отключение tls 1.2 рояля не играет. Гугла нет, но вы держитесь там, удачи.

    • Mdeah, so until next release we are doomed. My problem is with Outlook Mail that have stopped working for google accounts. So search until here. Disabled TLS 1.2 1.1:)) This is serious guyz, please release a fix for it.
      Private window doesn’t help my outlook even if i’m logged on gmail.
      Nice to hear that more security for Bearer tokens will arrive.

    • Feb 25th 2017 updated to the new insider preview 14986.rs_prerelease.161202-1928 and I am unable to browse to www.google.com from Edge or IE11. I am able to do so from Firefox. Unchecking the TLS 1.2 allows me to get to www.google.com in IE only and only after I go to translate.google.com first. Gmail does not work either way. If the new update performs like this, I will have to recommend that we skip this update when released.

    • Can confirm error and “InPrivate” workaround
      Microsoft Edge 39.14986.1000.0
      Windows 10 Pro Insider Preview, Version 1607, Build 14986.1001

      MS, how agile are you? Shouldn’t this be fixed by now?

    • to the complainers: we are insiders and we should expect things not to work correctly. That’s the whole purpose of the program.

    • Microsoft. At this point you have gone FULL retard. You NEVER go FULL retard!
      I have completely switched over to using Chrome. If you don’t fix this by releasing a new update by tomorrow, I’m done with the slow ring. Because the slow ring is full retard.

    • To Shane T:

      This has been an issue for months. I expect faster releases.
      This has gone into full retard mode.

    • To Shane T.
      Yes you’re right, we’re Insiders and we should expect that things don’t work perfectly.
      BUT I’m on the slow ring. This should not have been released on slow ring with such a critical issue.
      With a critical issue like this I should not need to search for a solution. It’s a known bug with a work round. When it’s released on the slow ring it should have been either fixed or we should have been informed of the work round. This is not a trivial issue that only a few people would encounter.
      Part of the issue is bundling updates to apps into OS updates but also the Forum system is not helpful. Part of that is down to poor discipline on our part with not using informative titles in posts (this is one of the better ones), partly Microsoft for not grouping posts into releases but also the system itself for not promoting the solution as a ‘sticky’ at the top.

    • To Shane T.
      With such tremendous bugs the whole purpose of the program is ONLY ONE:
      Chrome/Firefox and slow ring or out of the program!!!
      =>congrats the program has reached its goal

    • Everyone’s right:

      1. This bug is ridiculous and they should have pushed a fix by now.
      2. The up side: I like to think they have learned something from this. Part of the reason there haven’t been slow ring updates since december might be they are vetting builds harder before they release them.
      3. On the down side: If Microsoft websites were affected that build wouldn’t even gotten into the fast ring. Agile development does not mean "untested features".
    • Issue definitely not fixed. Over 2 months of poor Edge performance.

    • Issue has been fixed in build 15046

    • Yes, but has that build been distributed and to whom? 14986 shouldn’t have gotten in to the slow ring this way. If it were for something more esoteric, but opening Google in Edge? And then staying two further months unfixed for those users? C’mon. Colleagues felt reminded of the 1990s.

    • For me this highlighted a few issues with the slow ring. Bugs are going to creep in from time to time in any ring, but while the fast ring has a fairly dependable cadence (we tend to get a new build at least every week) and the release preview ring is reserved for critical fixes and testing leading up to a release, the slow ring is the gray area in between. If something creeps in and makes us bonkers we need to make a call whether we roll back, jump to the fast ring, or wait for a new slow ring build. While there’s a lot of good information out there about new fast ring builds that help anyone making a cost / benefit risk decision, there’s really not much help around the waiting option and either a quasi-reliable cadence or maybe a heads up on the Insider announcements would be great. If you agree with this, please do upvote this feedback to Microsoft: https://aka.ms/O041nk

    • Just learned about this problem the hard way today, after computer reboots into newly updated 14986 build (on slow ring). Can’t access any google services (including embded youtube videos) on MEdge unless the browser is InPrivate mode. Chrome is not affected.

      Why is this issue marked as fixed if it’s not?

    • Fixed? I still can’t reach any google sites and I don’t want to “upgrade” to fast ring.

    • Can confirm that it is fixed on build 15048 for slow ring.

    • As of the beginning of this week, Google finance portfolios and charts not working in Edge unless, as above, I use Private browser. So the bug is NOT fixed. And after giving Edge 16 months of goodwill as my main browser, I’ve had enough. Back to Chrome it is.

    • It’s hard not to believe that disincentivising customers from using Google facilities is a hardball Microsoft strategy. It won’t work.

    • Really!!!, So I’m to understand that Microsoft is unsure to what is causing this ? “Some unstability should be expected” what ?!? I’ve even reinstalled to try to use Edge, after the reset then the update and back to square 1 with the TLS error. I’m going back to my Linux builds and Firefox and Chrome. Goodbye Microsoft. You really do…

    • Rony C. you are so funny!
      First, you are complaining for something you probably didn’t pay for… and second, you are complaining regarding a build that is in beta, which by definition might be instable and will have some bugs.

      Finally, problem is fixed in the latest “slow ring” 15058 build.

    • Guess Microsoft is paying you well. Good Luck stay with your b…I’m back to my Linux and Firefox. BTW I paid for the Windows 10 that I use with receipt to prove it. Bye

    • you are reading just half of my message.
      you are using a beta version.
      Windows Insider is a beta version released to public… and you chose to install this version… bugs should be expected.
      you can go back on the latest stable release and you won’t have those bugs.

    • Yes, we are using a beta (advanced release) versions of Windows and we do so both to experience new features, etc. before the standard build folks and to help vet Microsoft upgrades to hopefully make production version releases more rock solid than before. However, some of us (like myself) have chosen the slow release path and I would expect major issues like this Google issue to be found and fixed in the fast track before being moved to the slow track. In the slow track, my expectation is to be mostly stable with some minor usability issues to be unearthed under broader use. I am not asking for production levels of stability, just a usable platform.

    • I am using fast track insider preview version 15063 and both IE 11 and Edge work fine with all websites:-)
      However, my main desktop computer which has been using normal updates and builds until a few days ago and everything worked fine but I got hold of the latest Windows Installer for the new Windows 10 Creators update on the 27th March 2017 and decided to update my desktop to the new version.
      Big mistake:-( I now have the problem you people have. IE 11 and Edge will not open websites and the error about TLS settings pops up:-(
      Firefox works fine:-)
      Also Mail has gone berserk and has sent out to my contacts various old emails all re dated to latest date so recipients think I have gone loopy!!! I have also re received some emails that came weeks ago! Hope this will settle down but I am not sure I can trust Mail now.
      Come on Microsoft its time you had this problem sorted. PLEASE.

    • I just installed 15063.13 and cant access any google site using normal or inprivate in windows edge, but it works fine in internet explorer 11.

    • I’ve had the same issue and also with Chrome v56 & v57. We’ve tracked this down to our proxy. We are using Bluecoat as our and it’s not compatible with TLS1.3. If I use a different internet connection without proxy it works fine.

    • I have this issue in Creators Update (15063), I have tried several different “solutions” (like disabling TLS 1.2), InPrivate Browsing and others but none have helped me. I was really hoping to start using Edge now, but I guess I’ll have to wait a little bit longer :-(

    • Well I fixed it by installing fiddler, this meant everything worked while it was running.
      Then while it was running I turned off the proxy it sets up and it’s carried on working since then, without needing to run fiddler.

      So not sure what was going on after the update, but I do know I didn’t have any proxy running before the update, anyway hope that helps.

    • After installing the public Creator’s update on 3 computers I now can’t access a number of sites when using Edge. Google.co.uk and facebook.com are the ones I use most, and just don’t work. The symptoms are the same on all 3 computers (1 W10 Enterprise, one Pro & 1 Home editions). They work fine on IE11, just not Edge. Oh well, I guess I’ll have to bite the bullet and use Chrome, which I’ve managed to resist for so long.

    • I have the same issue after installing Creators Update, build 15063. Now when I try to do any research with Google the only result is a white page; no problem with other browsers.

    • I can’t access any site after the update :(

    • In IE 11 I am getting a flashing Black window, which eventually just goes Black, whenever I try to open a site like Google, Facebook or https://qlddet.service-now.com/sco/ . It seems it is anything where I have to input text such as a password or search criteria. Interesting that there is no issue with any of the Microsoft sites where text needs to be inputted.

      As soon as I navigate away from these sites it works correctly.

      I read through this post and have tried resetting IE, disabling TLS 1.2 etc etc but the issue persists.

      I can access the sites without error on all other browsers.

      Evaluation copy. Build 16170rs_prerelease.170331-1532

      It works correctly in Edge

    • Hi - this is definitely an issue, Microsoft. It has started happening with me since the Creators’ Update. I’ve been using Edge on my Surface of months, and really enjoy it. Now it is unusable given I use lots of Google services too.

      Ironically I’m switching back to Chrome until it’s sorted!

    • Yeah, this isn’t a 'bug’, this is horrible business practice by Microsoft. Blocking Google’s sites is childish. You can drown us in advertisements on the computers WE OWN but if you’re browser doesn’t open all sites on the internet, guess what? I’m going to use GOOGLE’S browser…I tried to give Edge a shot and it didn’t even last an hour…

    • To Jonathan B.
      If you read the history of this Microsoft and Google (and others) agreed a security update for the internet. Google didn’t implement it properly with the result that it gives a false spoof identity so IE and Edge block the site. In Private browsing allows access though.

    • Computer just updated last install ( creative update?) since then more often than not I am unable to use my home page which is google, very hit and miss, mostly miss.
      I am surprised that given the fact this problem has been ongoing for several months that a fix has not been found yet , and also that the creative update is still being rolled out.

    • This needs fixing ASAP, only got the update last night (29 April 2017), makes my machine totally useless as everything is linked to searching!

    • Just got the Windows 10 Creators update and while many sites work fine, several sites, such as Facebook, cannot connect using Microsoft Edge. The error code is INET_E_RESOURCE_NOT_FOUND. Exact same error using InPrivate Window. I have never had a problem prior to the update. Note that Chrome works fine.

    • I found this on another site an it worked for me:

      1. Type about:flags in the Microsoft Edge address bar
      2. Scroll down to the Networking section (near the bottom) and uncheck Enable TCP Fast Open
      3. Restart the browser
    • Tried latest suggestion from Ross…it worked fine for me.

    • Ok flags:about seems that work
      but why I with my pc and my account can browse Google sites, but my wife with her account and old pc cannot? can with Surface pro 4.

      Is it because the pc is slow?

      Anyway MICROSOFT EDGE TEAM investigate , search a pc with this problem, ask NAdella an air ticket to go to house of someone with ths problem.

      We think:

      1. you put something in the code to stop using Google sites
      2. Google doesn’t want we use Edge.

      I hate Google but videos are only on Google, bing works bad in languages different from american english. My wife have to use also a gmail account, translate from japanese to italian works better with Google translate. Bing is mostly for american english

    • I have one laptop experienced the issue after Creators Update as well.
      Noted Internet Explorer and other browsers can go to Facebook, YouTube, etc., while Edge can’t access those websites in most of the time.

      Ross H.’s solution in about:flags works for the laptop, and Edge can browse Facebook, YouTube now. Thanks! :)

    • I’ve now disabled TCP Fast Open in about:flags, which has fixed the Google issue. I would certainly like to know when this issue has been fixed so I can re-enable the setting.

    • After installing Windows 10 Creators update I cannot access google sites and facebook. I tried Ross H.’s solution in about:flags but that issue has not been fixed yet. If someone have any other solution then please help me.

    • If you got the latest update it was fixed. The bug appeared in the standard (non-insider) creator’s update and was fixed in the 15063.296 update.
      Amazing to see how many people subscribe to the ridiculous idea that Microsoft did it deliberately, but I guess ludicrous conspiracy theories are gaining more credibility these days thanks to Trumpety Trump.

    • My PC has updated this morning with the big update (Creator update?) and I have the same problem. Disabling the “USE TLS1.2” seems to have fixed this. Start menu / Control Panel / Internet Settings / uncheck "USE TLS1.2". Dunno if that is the right fix for this, but it has worked for me!

    • My laptop is current with the 15063.296 update and I still periodically experience these issues in both Chrome and MS Edge. Both browsers will not load Google pages (Google, Gmail, YouTube, etc). They just freeze up when attempting to do so. My only solution has been a restart of the system, sometimes it takes several restarts and then it starts behaving normally with no clues as to what happened.

    • Thanks Paul O. I took a shower and eat breakfast and the June update for my WIN 10 PC was still farting around. Will try your suggestion.

    • I got my first device from Dell repair today and it came with this ridiculously useless Windows 10 Creators Update build 15063.332 and I can no longer access our facilities’ Electronic Medical Records system on Point Click Care. What in God’s name did Microsoft do to the OS/Internet Explorer and what is the fix? I know for a fact that the servers support TLS so it is NOT because the site is using an outdated or unsafe TLS security setting. This is unacceptable to the business world and sure as heck for the Medical Industry!

    • I tried Paul O’s suggestion and it cleared up most of my issues with this subject. But, I have noticed that continually clicking Refresh will get me where I want to be on troublesome sites. However, I have a very slow cable connection that complicates the Refresh issue.

    • Since June Updates I am getting throw out(closed out) of MS Edge just like I was in I.E.11, same problem of a "faulting module".
      “Faulting module name: ntdll.dll, version: 10.0.15063.0, time stamp: 0xb79b6ddb”
      I was getting along fairly well with TLS1.2 unchecked

    • In the past two days MS Edge simply closes a minute or so after loading. My favourites and default settings are lost and it closes down too quickly for me to access settings. Fortunately I have Chrome loaded on my laptop but the favourites are out of date. What a nuisance!!!

    • This MS Edge build 15063 should be separate discussion so we can keep track of it , or is this a “Creator” issue? This Creator update is just plain stupid. I have to use search just to find my screen saver settings.

    • Can’t access any Google sites in Edge and IE11 . This has been going on about a month after some Microsoft updates took place.
      It is very frustrating and appears that Microsoft is trying to block Google search engine and trying to promote their own search engine Bing.com

    • Intermittently receive error “Cannot securely connect to this page,This might be because the site uses outdated or unsafe TLS security settings. If this keeps happening, try contacting the website’s owner.” on multiple https sites. This started happening after update to Windows 10 Creator’s update Build 15063.502

    • My website relies on google maps to show where the real estate properties are located. It’s a real estate website in Southern Spain. https://www.tmtspain.com property locations and icons render well in every browser except MS Edge. The only way the maps can be seen is to go back to Internet Explorer or open a new InPrivate Window in Edge. Anyone surfing with Edge in ordinary view and accessing my website will get a botched version. Really doesn’t seem fair.

    • Can’t connect securely to this page on all browsers. Chrome, Edge, IE on Windows 10 after MS updates. Unchecked TLS settings in internet options. Chrome Setup which I downloaded on another working pc then installed on this one and it worked thru download but webpage would not open. Still no fix!!! guys???

    • The TLS issue still exists, I’ve been toggling TLS1.2 on and off for months now. What’s going on?

    You need to sign in to your Microsoft account to add a comment.

    Sign in