Microsoft Edge does not redirect to pages of URLs containing UTF8 characters properly

Not reproducible Issue #10326253

Details

Author
Sung K.
Created
Dec 28, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
38.14393
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

My site that have a URL structure of eg. /article/14/Title-Of-Article

And when users enter someting like /article/14/ttt (a wrong title), we will forward the user to the more “correct” URL (as we know they refer to which article because we have the id) so to be more consistent.

All browsers (Chrome, Firefox, Safari or even the old Internet Explorer!!) are doing it fine. BUT in Edge, when the correct URL contains UTF8 characters (eg. Chinese), it would show an error page and say that the website cannot be reached. But note that if the user enter the correct URL in the first place, the site is able to show.

It is probably because the UTF8 characters in URL (or during redirect) cannot be encoded properly in Edge.

Thank you.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Brad E.”

    • I confirm I have the same kind of issue with redirects to Chinese URLs (zh-tw).

    • Microsoft Edge Team

      Changed Assigned To from “Brad E.” to “James M.”

      Changed Status to “Not reproducible”

    • Hello,

      Thank you for providing this information about the issue. We are unable to reproduce this problem in Edge with the information at hand. Please reopen this case when you can provide more details, such as screenshots or a sample website.

      Best Wishes,
      The MS Edge Team

    • Hi,
      Thanks for having a look. After testing again, it seems the issue got solved in a recent update… So you can probably close the ticket.
      Kind regards,
      Adrien

    You need to sign in to your Microsoft account to add a comment.

    Sign in