Audio Element - playing event is not triggered after seeking

Duplicate Issue #10437243 • See Issue #11444072

Details

Author
Greg
Created
Jan 6, 2017
Privacy
This issue is public.
Duplicates
See progress on Bug #11444072
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

Hi,

I am seeing a behavior with Edge that I am not seeing with other browsers (Chrome, Firefox), when an audio file is current playing and I seek (audio.currentTime = x), the audio element does not trigger a playing event to notify that playback has resumed.

It is even more important with MSE because I could seek to a position that is not buffered yet and I have no way to know that playback has resumed.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Brad E.”

    • I realised I can rely on the `seeked’ event.

    • Microsoft Edge Team

      Changed Status to “Not reproducible”

    • Hello,

      Thank you for sharing your problem and solution. If you find further trouble with this specific issue, please feel welcome to reopen the case.

      Best Wishes,
      The MS Edge Team

    • Microsoft Edge Team

      Changed Assigned To to “Matthew H.”

      Changed Status from “Not reproducible”

      Changed Status to “Duplicate”

    • This bug has marked as duplicate. Please follow the parent issue to get new updates.

    • Microsoft Edge Team

      Changed Title from “Audio MSE - playing event is not triggered after seeking” to “Audio Element - playing event is not triggered after seeking”

    You need to sign in to your Microsoft account to add a comment.

    Sign in