Dont load websites with HTM file extension...

By design Issue #10440093

Details

Author
Vague S.
Created
Jan 6, 2017
Privacy
This issue is public.
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

I dont know why, but i cant open and load websites with HTM file extensions, example :

wrestlinginc.com

If i try, Edge just download a blank HTM file.

Attachments

1 attachment

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Ibrahim O.”

  • Thank you for your feedback. The URL you have provided works fine on MS Edge. Could you please verify your OS version(winver.exe) and the sample URL?

    Best regards,
    The MS Edge Team

  • Come on, what OS will be ? Windows Millenium ?

    Of course that is Windows 10 Version 1607.

    Look, when i try to access that website (WrestlingInc), Edge just download a HTM file, he dont load the webpage. Here is the data inside the downloaded HTM file.

    http://pastebin.com/WNGJLYUX

    Maybe this is a bug created by some reg cleaners like CCleaner, WinUtilities ??? Because use them from time to time, and you know, these apps cause problens in the Windows Register sometimes.

  • I uploaded the HTM file in the attachment, take a look.

  • Appreciate the update. To be able to triage the issue, it needs to be reproducible on our environment or need enough data to be able to investigate the issue. Could you please provide us your fiddler network trace? That will help our investigation.

    All the best,
    The MS Edge Team  

  • I seem to be experiencing a similar issue when I am using the uBlock Origin extensio. In Edge on Windows 10 1607 (OS Build 14393.693) when I try to go to the UPS site to track a package using http://wwwapps.ups.com/WebTracking/processInputRequest pasted into the address bar I get prompted to download processInputRequest.htm. If I turn off uBlock Origin the page renders correctly.

  • I’m also having this issue, it tries to download instead of rendering any website using htm extensions, like . I’m using uBlock Origin too and disabling it fixes the issue so either the extension is doing something wrong or an API it uses is broken.

  • Microsoft Edge Team

    Changed Assigned To from “Ibrahim O.” to “Steven K.”

  • Hi,

    Thank you for the responses.

    The MIME types are typically configured in the web server.  The client browser can sometimes over-ride these settings.

    In this specific case, it appears that the issue has been resolved for the URLs listed in the latest Windows public release which is 14393 at the time of writing.  It could also be the case that this issue only happened due to the extension’s use.

    It appears that the uBlock Origin extension is making modifications to the data.  Can someone run a test with the extension enabled and capture a fiddler trace and upload it here?

    http://www.telerik.com/fiddler

    Appreciate the help,

    The MS Edge Team

  • I’m having the same issue, and also using uBlock, so as others mentioned, appears to clearly be an issue there.

  • Microsoft Edge Team

    Changed Status to “By design”

  • Thank you Will.

    I am closing this as won’t fix/by-design since the issue is outside of Edge.

    Appreciate the submission and updates,

    The MS Edge Team

  • Steven K:

    Seems to be an issue with Edge, actually:
    https://github.com/nikrolls/uBlock-Edge/issues/45

You need to sign in to your Microsoft account to add a comment.

Sign in