XMLHttpRequest incorrectly throws InvalidStateError when setting responseType before sending an XHR request

Not reproducible Issue #104817

Details

Created
Apr 27, 2014
Privacy
This issue is public.
Found in build #
0.0011
Reports
Reported by 0 people

Sign in to watch or report this issue.

Steps to reproduce

Repro page: http://ie-snap/scratchtests/dalecox/xhr/invalidStateError.html

URL:

Repro Steps:

I’ll attach a simple HTML file to reproduce.

  1. Open sample
  2. Open F12 Developer Tools
  3. Click allow running blocked content
  4. Click on console within F12
  5. Note the error:

HTML1300: Navigation occurred.
File: invalidStateError.html

SCRIPT5022: InvalidStateError
File: invalidStateError.html, Line: 8, Column: 1

Sample HTML:
<!DOCTYPE html>
<html lang="en">
<head>

<script>

var xhr = new XMLHttpRequest();
xhr.responseType = "blob";
var b = xhr.responseType === "blob";

</script>

</head>
<body>

</body>
</html>

Expected Results:

Code should execute without error.

Actual Results:

Error logged in F12 console when using IE
No Error logged when using Chrome

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Venkat K.”

      Changed Assigned To from “Venkat K.” to “Matt K.”

      Changed Assigned To from “Matt K.” to “IPBS P.”

      Changed Status to “Won’t fix”

      Changed Assigned To from “IPBS P.” to “Venkat K.”

      Changed Assigned To to “Venkat K.”

      Changed Status from “Won’t fix”

      Changed Assigned To from “Venkat K.” to “Nicolas A.”

      Changed Assigned To from “Nicolas A.” to “IPBS P.”

      Changed Status to “Not reproducible”

    • I am facing this issue too. Is there a workaround for the bug till a fix or patch is released by Microsoft.

    You need to sign in to your Microsoft account to add a comment.

    Sign in