@ character is not converted to %40 when transmitted in a form

Fixed, not yet flighted Issue #108125

Details

Created
Apr 27, 2014
Privacy
This issue is public.
Found in build #
0.0011
Reports
Reported by 0 people

Sign in to watch or report this issue.

Steps to reproduce

URL =

URL:

Repro Steps:

  1. Open IE to about:blank
  2. Launch Fiddler or F12 network tools
  3. load http://androidinahurry.com/test.html
  4. Click submit

The email address is sent to the server but the ‘@’ is not URL Encoded.

Expected Results:

The @ character should be converted to %40.

Actual Results:

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Mara P.”

      Changed Assigned To from “Mara P.” to “IPBS P.”

      Changed Status

      Changed Assigned To from “IPBS P.” to “Venkat K.”

      Changed Assigned To from “Venkat K.” to “Matt K.”

      Changed Status to “Confirmed”

      Changed Assigned To from “Matt K.” to “Rajat J.”

      Changed Status from “Confirmed” to “In progress”

      Changed Status from “In progress” to “In code review”

      Changed Status from “In code review” to “In progress”

      Changed Status from “In progress” to “In code review”

      Changed Status from “In code review” to “In progress”

      Changed Assigned To from “Rajat J.” to “IPBS P.”

      Changed Status from “In progress” to “Fixed”

      Changed Assigned To from “IPBS P.” to “Venkat K.”

      Changed Status from “Fixed” to “Fixed, not yet flighted”

    You need to sign in to your Microsoft account to add a comment.

    Sign in