IE 11 || TLS 1.2 || Client side certificates no longer being presented to web server (intermittent) Works if TLS 1.2 is turned off.

By design Issue #108132

Details

Created
Apr 27, 2014
Privacy
This issue is public.
Found in build #
0.0011
Reports
Reported by 0 people

Sign in to watch or report this issue.

Steps to reproduce

URL =

URL:

Repro Steps:

Navigate to website requiring client side SSL certificate authentication
IE requests user to select certificate (if one has been imported)
User selects certificate
IE does not provide the certificate to web server (confirmed in SSL handshake with Apache)
Web server does not authenticates user and they are presented with a 403 error

Expected Results:

Navigate to website requiring client side SSL certificate authentication
IE requests user to select certificate (if one has been imported)
User selects certificate
IE provides certificate to web server
Web server authenticates and allows user to continue browsing site

Actual Results:

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “IPBS P.”

      Changed Assigned To from “IPBS P.” to “Bruce M.”

      Changed Assigned To to “Kamen M.”

      Changed Assigned To to “Venkat K.”

      Changed Assigned To from “Venkat K.” to “Ivan P.”

      Changed Status to “Confirmed”

      Changed Assigned To from “Ivan P.” to “Andrei P.”

      Changed Assigned To from “Andrei P.” to “IPBS P.”

      Changed Status from “Confirmed” to “By design”

      Changed Assigned To from “IPBS P.” to “Gopinathan K.”

      Changed Assigned To from “Gopinathan K.” to “Yanapol S.”

    You need to sign in to your Microsoft account to add a comment.

    Sign in