isDisplayed() returns false for linkText

Not reproducible Issue #11077507

Details

Author
Nikunj R.
Created
Feb 26, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Description:
We have an anchor tag with “Contact us” text in it.<
a href="/contact_us">Contact us

Finding this element By.linkText(“Contact us”) works fine. However, calling .isDisplayed() method on an web element returns false.

Step to reproduce:
When we execute below code snippet:
WebElement el = getDriver().findElement(By.linkText(“Contact us”));
System.out.println("Is displayed?: "+el.isDisplayed()); //This always returns false.

Note:
This works fine in Chrome, Firefox, and IE[7-11] browsers. Issue is only identified in Edge browser.

Version info:

  1. selenium-server-standalone-3.1.0
  2. Edge Driver: Release 14393, Version: 3.14393
  3. Edge Browser Version: 38.14393.0.0
  4. Microsoft EdgeHTML 14.14393

Attachments

0 attachments

    Comments and activity

    • Changed Steps to Reproduce

      Changed Steps to Reproduce

      Changed Steps to Reproduce

      Changed Steps to Reproduce

      Changed Steps to Reproduce

      Changed Steps to Reproduce

      Changed Steps to Reproduce

      Changed Steps to Reproduce

      Changed Steps to Reproduce

      Changed Steps to Reproduce

    • Microsoft Edge Team

      Changed Assigned To to “Mara P.”

      Changed Assigned To from “Mara P.” to “Mustapha J.”

    •   Can you please share url to the page where you see this issue happen on? I’ve created a simple page with only <a> contact us tag and wasn’t able to reproduce this issue.

    • Microsoft Edge Team

      Changed Title from “isDisplayed() returns false for linkText” to “isDisplayed() returns false for linkText”

      Changed Assigned To from “Mustapha J.” to “Clay M.”

    • Hey Nikunj,

      Would it be possible to get a jsbin or pastebin of the markup of the page so we can try to reproduce it here and debug the issue?

      Thanks,
      Clay

    • Microsoft Edge Team

      Changed Status to “Not reproducible”

    • I’m going to close this as not repro for now as we need a page to repro against. Please reactivate the bug and attach sample markup where webdriver is failing and we’ll investigate further.

    You need to sign in to your Microsoft account to add a comment.

    Sign in