load event doesn't fired for PDF in IFRAME

Not reproducible Issue #110900

Details

Created
Apr 27, 2014
Privacy
This issue is public.
Found in build #
0.0011
Reports
Reported by 0 people

Sign in to watch or report this issue.

Steps to reproduce

Use Case from the Customer:

Posted
by RichardJECooke

on 8/21/2015 at 5:25 AM

Here’s
a use case my government department clients (that use IE as their primary
browser) demand: Print a PDF when clicking a single button (when the PDF is
dynamically created on the server). A hidden iframe with a print onload event
is the only way to do it.

URL:

Repro Steps:

  1. Launch IE 11
  2. Navigate to http://andronova.de/test.html
  3. Text ‘HTML IFrame loaded’ and ‘Embed IFrame loaded’ should appear

Note: This works as expected in Edge and Chrome, but not IE11 (a yellow bar appears at the bottom in IE asking the user to save or open the PDF)

Expected Results:

load event should be fired for any content on completed loading

Actual Results:

 

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Tony S.”

      Changed Steps to Reproduce

      Changed Status to “Confirmed”

      Changed Assigned To from “Tony S.” to “Sermet I.”

      Changed Assigned To from “Sermet I.” to “Ted D.”

      Changed Assigned To from “Ted D.” to “IPBS P.”

      Changed Status from “Confirmed” to “Won’t fix”

      Changed Assigned To from “IPBS P.” to “Vidya N.”

      Changed Assigned To to “Bogdan B.”

      Changed Title from “load event doesn't fired for PDF in IFRAME” to “load event doesn't fired for PDF in IFRAME”

      Changed Steps to Reproduce

      Changed Assigned To to “Ted D.”

      Changed Status from “Won’t fix”

      Changed Assigned To to “Sermet I.”

      Changed Steps to Reproduce

      Changed Assigned To from “Sermet I.” to “IPBS P.”

      Changed Status to “Not reproducible”

      Changed Steps to Reproduce

    You need to sign in to your Microsoft account to add a comment.

    Sign in