getExtensions command does not return valid JSON when multiple extensions are present

Fixed, not yet flighted Issue #11141785

Details

Created
Mar 2, 2017
Privacy
This issue is public.
Found in build #
15.15044
Reports
Reported by 0 people

Sign in to watch or report this issue.

Steps to reproduce

When trying the /browserexts command with multiple extensions installed, I received the following JSON response:

{"sessionId":"F713CBC8-A8BA-42E6-AC0F-2FC4E0F9F56D","status":0,"value":[{"id":"2016_MicrosoftOfficeOnline_8wekyb3d8bbwe"}{"id":"10_EyeoGmbHAdblockPlus_d55gg7py3s0m0"}{"id":"EdgeExtension_BetaFishAdBlock_c1wakc4j0nefm"}{"id":"EdgeExtension_MicrosoftMicrosoftPersonalShoppingAssistant_8wekyb3d8bbwe"}{"id":"EdgeExtension_GhosteryGhostery_kzkqe0pn505dg"}{"id":"EdgeExtension_37833NikRollsuBlockOrigin_f8jsg5mm64m62"}{"id":"MicrosoftTranslate_MicrosoftTranslatorforMicrosoftEdge_8wekyb3d8bbwe"}]}

We are missing commas between each of the extension objects returned.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Anshul K.”

      Changed Title from “WebDriver getExtensions command does not return valid JSON when multiple extensions are present” to “getExtensions command does not return valid JSON when multiple extensions are present”

      Changed Status to “Confirmed”

      Changed Status from “Confirmed” to “In progress”

      Changed Status from “In progress” to “In code review”

      Changed Status from “In code review” to “In progress”

      Changed Status from “In progress” to “In code review”

      Changed Assigned To from “Anshul K.” to “Scott L.”

      Changed Status from “In code review” to “Fixed”

      Changed Status from “Fixed” to “Fixed, not yet flighted”

    You need to sign in to your Microsoft account to add a comment.

    Sign in