ChildNode.remove() not working with <select> element

Fixed Issue #11318983

Details

Author
Daniel W.
Created
Mar 18, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Standard affected
W3C DOM4

Found in build #
14.14393
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

The .remove() method of the Node object doesn’t seem to be working for `` elements. Using the following HTML:



  
    
    Bug

  

  
    
      opt 1

      opt 2

    

  



Running the following script in the console (or in a script tag) has no effect:

document.querySelector('select').remove()

Attachments

0 attachments

    Comments and activity

    • Changed Steps to Reproduce

      Changed Steps to Reproduce

      Changed Steps to Reproduce

      Changed Steps to Reproduce

      Changed Steps to Reproduce

      Changed Steps to Reproduce

      Changed Steps to Reproduce

    • Microsoft Edge Team

      Changed Assigned To to “Steven K.”

      Changed Status to “Fixed”

    • Hi Daniel,

      I wanted to let you know that I repro’d this in 14393.1066.   I also wanted to let you know that this is fixed in the latest insider fast build 15063.138.

      Also, I created a repro in case you want to verify it is the same issue you reported:

      https://jsfiddle.net/uncnqrd/44n10sek/8/

      Thank you for the submission,

      The MS Edge Team

    • Great! Thanks for all your awesome work!

    You need to sign in to your Microsoft account to add a comment.

    Sign in