Youtube Live Streaming is stuttering on Edge even with enough buffer

Needs root cause Issue #11424575 • Assigned to Erik A.

Details

Author
Kagami R.
Created
Mar 28, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
15.15063
Needs root cause
Sign in to suggest a root cause.
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

  1. Go https://youtu.be/DZMAFQDPeQY
  2. Play and seek several times

Tested on video quality Auto (720p HD). CPU usage skyrockets to 100% (Edge 50%) on Surface 3 (non-pro), even when I paused the video. Closing the tab returns the usage.

Attachments

Comments and activity

  • Changed Steps to Reproduce

    Changed Steps to Reproduce

    Changed Steps to Reproduce

  • Microsoft Edge Team

    Changed Assigned To to “James M.”

    Changed Status to “Not reproducible”

  • Hello,

    Thank you for providing this information about the issue. After thorough testing, we are unable to reproduce this problem in Edge public and insider builds. It is normal for the CPU usage to increase while seeking and to decrease while paused, which is what we see. For further assistance, please try the same repro on a different machine and let us know the results.

    Best Wishes,
    The MS Edge Team

  • Changed Status from “Not reproducible”

  • No, it does not decrease while paused, as I wrote. I can repro this on my Core i5-2400 + Radeon HD 5750 desktop machine.

  • Just uploaded a repro GIF where you can see pausing does not help.

  • Microsoft Edge Team

    Changed Assigned To to “James M.”

  • Hello,

    Thank you for providing this information about the issue. We ran tests on a Surface 3 with i5 processor but could not repro this problem.

    1. Please open a new InPrivate window and run the test in Edge again to see of this makes a difference, and let us know the results.
    1. Also, please run your test on a video which is not live-streaming and provide us with those results.

    These two test scenarios will help us determine what might be causing the problem. We appreciate your help with this case.

    Best Wishes,
    The MS Edge Team

  • I think you tried Surface ‘Pro’ 3. Surface 3 uses Atom X7 processor instead of Core i5.

    1. I tried InPrivate and it still repros on live-streaming.
    2. Non-live videos does not repro this problem, 4-8% usage even when playing.

    I watched F12 Network tab and found that requests for video files are super-frequent when CPU usage is high, and no requests when the usage is low. The video was both paused when I saw them. I recorded that with Fiddler and will upload as youtube-edge.saz file.

  • Here: https://1drv.ms/u/s!ArDhQNmhsUj028huC8akSOWn7P0E5w

    Attachment on this tracker failed. :/

  • Similar thing happened on Firefox but CPU usage was not that high (10%). https://1drv.ms/u/s!ArDhQNmhsUj028hvztDbXovZSd2n9w

    Both were recorded after seeking to the middle of the stream and then pausing right away.

  • Microsoft Edge Team

    Changed Assigned To to “Venkat K.”

    Changed Assigned To from “Venkat K.” to “Erik A.”

    Changed Status to “Needs root cause”

You need to sign in to your Microsoft account to add a comment.

Sign in