MoveToElement function moving to wrong coordinates

Confirmed Issue #11469232 • Assigned to John J.

Details

Author
Sachin N.
Created
Mar 31, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

For Edge 38.14393.0.0 version, MoveToElement function moving to wrong coordinates
I am using below details:

  1. Selenium Standalone Server 3.3.1 -> RemoteWebDriver
  2. C# Client Lib 3.3.0
  3. Microsoft Edge Driver from https://developer.microsoft.com/en-us/microsoft-edge/tools/webdriver/ -> Release 14393

4: Remote WebDriver Capability Details are as follows:
_capabilities = DesiredCapabilities.Edge();
_capabilities.SetCapability(CapabilityType.BrowserName, “MicrosoftEdge”);
_capabilities.SetCapability(CapabilityType.Platform, “WIN10”);
_capabilities.SetCapability(CapabilityType.AcceptSslCertificates, true);
_capabilities.SetCapability(CapabilityType.HasNativeEvents, true);
_capabilities.SetCapability(CapabilityType.IsJavaScriptEnabled, true);

EdgeOptions edgeOptions = new EdgeOptions();
edgeOptions.AddAdditionalCapability("ignoreZoomSetting", true);
edgeOptions.PageLoadStrategy = EdgePageLoadStrategy.Normal;

_capabilities = (DesiredCapabilities)edgeOptions.ToCapabilities();

5: WebElement Details are as follows:
[FindsBy(How = How.XPath, Using = "//*[contains(@id,’Logout’)]")]
[CacheLookup]
private IWebElement lnkLogout { get; set; }

6: Please find attached screenshot for my Browser Version Details.

7: Display Resolution : 1366 x 768

Attachments

Comments and activity

  • Changed Steps to Reproduce

    Changed Steps to Reproduce

    Changed Steps to Reproduce

    Changed Steps to Reproduce

  • Microsoft Edge Team

    Changed Assigned To to “James M.”

  • Hello,

    Thank you for providing this information about the issue. After testing, we are unable to reproduce this problem in Edge. Please test this behavior in our latest insider build 15063 and confirm you still have the same problem.

    Best Wishes,
    The MS Edge Team

  • I am not able to open Edge Browser using 15063 Microsoft Edge Driver.
    Please find attached screenshot for more details from Selenium Client Console

  • I am not able to open Edge Browser using 15063 Microsoft Edge Driver
    Please find attached screenshot for more details from Selenium Client Console

  • Hello,
    I am not able to open Edge Browser using 15063 Microsoft Edge Driver
    Please find attached screenshot for more details from Selenium Client Console

    Thanks & Regards,
    Sachin N

  • Sorry for same multiple comments but this web application is not refreshing page when we add new comment, So I was confused.

  • Microsoft Edge Team

    Changed Assigned To to “Mike J.”

    Changed Assigned To from “Mike J.” to “John J.”

    Changed Status to “Confirmed”

You need to sign in to your Microsoft account to add a comment.

Sign in