100% CPU usage/hang in Edge on earbits.com (not seen in Chrome)

Won’t fix Issue #11472742

Details

Created
Mar 31, 2017
Privacy
This issue is public.
Found in build #
14.14967
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Repro steps:

  1. Go to earbits.com in Edge.
  2. Click on a genre and select a channel to start music playing.
  3. Let the music play in the background for a couple hours.
  4. Eventually the music will get stuck in between songs for long periods of time. CPU usage during this will be 100%

No repro in Chrome on same machine.

 

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “ecoengie”

      Changed Status to “Site Outreach”

      Changed Assigned To from “ecoengie” to “Kelly Y.”

      Changed Steps to Reproduce

    •  The Edge Team has investigated and found the site is doing a setInterval call, which creates a new recurring timer and it doesn’t reschedule the existing timer. So each call creates an additional timer and then this usage pattern results in the count of timers to grow exponentially over time. It is recommended to call setInterval once, and not call it in the callback.

       

      A good explanation can be found here:

      http://stackoverflow.com/questions/2696692/setinterval-vs-settimeout

       

      We are currently outreaching to the site owners and asked them to investigate/fix. 
       

    • Microsoft Edge Team

      Changed Assigned To from “Kelly Y.” to “Web P.”

      Changed Status from “Site Outreach” to “Won’t fix”

    • This is an issue that should be fixed by earbits.com.  The Edge team has outreached and we are resolving the issue.

    You need to sign in to your Microsoft account to add a comment.

    Sign in