Edge fails to load Google

By design Issue #11679877

Details

Author
Francesco M.
Created
Apr 16, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

When I try to do any research with Google.com, Google.it, etc. the only result I get is a white page: this issue happens since I have installed Creators Update, build 15063. I have no problems with other browsers. Does anybody have any suggestions?

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Steven K.”

  • Hi Francesco,

    What is your default search engine set to?

    Have you tried clearing your browsing history?

    Here is the link for instructions on clearing your browser history.

    https://support.microsoft.com/en-us/help/10607/microsoft-edge-view-delete-browser-history

    The MS Edge Team

  • Hi Steven,
    Eventually, the loading fails and I get: There was a temporary DNS error. Try refreshing the page. Error Code: INET_E_RESOURCE_NOT_FOUND
    However, I can see with Microsoft Message Analyzer that DNS requests are being sent, and the responses contain valid IP addresses. Another interesting thing that I’ve noticed is that using Fiddler as a proxy makes the problem go away. Loading it in an InPrivate window does not fix the issue.
    Thanks,
    Philip

  • Hi Steven,
    thanks for your answer.
    My default search engine is set to Bing and I have no problems with it; I’ve already tried to clear my browser history, but no benefits arise.

  • Update: I’ve just noticed that it takes from 5-6 minutes to load www.google.com: the page remains white for 5-6 minutes and then the google page appears. I specify that all other pages load instantly, so it shouldn’t be an internet connection problem.

  • Hi Francesco,

    Would you be willing to load the site with the debugger/F12 open?  I would like to see the output of the console tab, and also the network tab.  The network tab will show the timing for various requests and files.  This should make it clearer what area we should focus on.

    Steven

  • I was never able to get anything to show up in the F12 network tab. I tried a few things and found that if I disabled TCP Fast Open, it was able to load Google sites consistently. I’m not sure if this is the same problem Francesco was having.

  • Thanks you all for your kindness. I’ve disabled TCP Fast Open following Philip’s tip, and it actually seems to work: Google page now loads instantly. Anyways, I’ve added a picture showing the console tab and a file I got from saving the network tab in order to shed some light on this issue.

  • Francesco,

    Can you let us know what you have set for 'TCP Fast Open’?  See the attached PNG.

    Also, if the network tab in the debugger is not useful for you can you also run Microsoft Message Analyzer?  Do not send the capture unless you send it private and have removed any personal information.  Ideally, delete everything except the traffic to and from www.google.com.  A screenshot should be sufficient.

    Steve

  • Hi Steven,
    Interestingly, I can no longer reproduce the problem. Yesterday, I enabled TCP fast open, failed to load the page; disabled TCP Fast Open, loaded the page successfully; and repeated the whole cycle at least twice more. Today, it seems that regardless of whether or not TCP Fast Open is enabled, the page loads!
    I’m not sure if Google changed their server or something in my local network changed. I know which IP address www.google.com resolves to has changed, but even manually using the old IP address did not cause the problem to return. I’ll keep TCP fast open on and see if it comes back.
    I do have a recorded network trace from yesterday demonstrating the problem, but I don’t see how to send it privately. It looks to me just like a failure to connect at the TCP level.
    Thanks,
    Philip

  • Well, that was fast. The problem is already back. When TCP Fast Open is enabled, it doesn’t load Google pages. I have a good network trace I’m happy to send. It looks like it just never receives the SYN-ACK packet. I don’t know enough about the Fast Open protocol to understand exactly why that is happening.
    Thanks,
    Philip

  • Hi Philip,

    Exactly the issue and great timing, except you beat me, which I wish happened more often.  :-)

    I just took a Wireshark capture as well of a new session to youtube and saw that youtube is not generating a TCP Fast Open cookie.  See the attached image to see the request packet showing the cookie request.

    Here is a presentation from a Microsoft employee giving a quick overview of the protocol and the requests of the Client, Edge in this case, and the Server, youtube.com in this case.  On slide 3, you will see that the server needs to create and send a TCP Fast Open cookie.

    https://www.ietf.org/proceedings/96/slides/slides-96-tcpm-4.pdf

    TCP Fast Open also relies on this feature being supported by all the routers and load balancers in between the client and the server.

    I realize you don’t need to know how to find the Syn and Syn-Ack packets, however, I found these filters useful and thought others who find this may as well.

    tcp.options.tfo  // TCP Fast Open option set.
    tcp.options.tfo.cookie   // a cookie is present in response to the cookie request, i.e. from the Server in this case and required for the feature to work, i.e., the issue in this case.

    Appreciate the support,

    The MS Edge Team

  • I mentioned youtube as there was another bug submission a while back for the same issue but with youtube.  I actually, captured traffic for both sites, youtube.com and google.com with the same result, i.e. missing the Syn-Ack cookie from the server.  Could of course, be any of the “middle boxes” in between.

  • For completeness, the workaround/fix is to disable “TCP Fast Open” in Edge.

    This is done by opening entering “about:flags” in Edge’s address bar.  See the attached screenshot.

    The MS Edge Team

  • Microsoft Edge Team

    Changed Status to “By design”

  • Hi Philip and Francesco,

    I am moving this ticket to resolved “working as designed” because this issue appears to related either the network boxes or the end server’s lack of support for TFO.

    Let us know if you discover any situation where the Syn cookie is sent from the server and Edge does not handle it correctly, and of course, any other issue you may find.

    Appreciate the extra debugging and support on this issue,

    The MS Edge Team

You need to sign in to your Microsoft account to add a comment.

Sign in