Edge 15 Video playback

By design Issue #11758168

Details

Author
Charles T.
Created
Apr 23, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
15.15063
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

So I have two main issues with the video playback in Microsoft Edge HTML 15.15063. First, I can’t play .webm videos in the browser. Second, for some websites that use Adobe Flash or Kernel player, the browser now says "This type of video file isn’t supported". Could a developer or someone appropriate please fix these issues and create an update for Microsoft Edge? I would really appreciate it.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Steven K.”

    • Would you be willing to provide more information related to what you are seeing?  We need enough information to be able to repro the issue.

      https://blogs.windows.com/msedgedev/2016/04/18/webm-vp9-and-opus-support-in-microsoft-edge/#Xvz3ol1Ue32bLdtw.97

      Also, can you double check that Flash is still enabled in Edge?  This is in under Settings --> “View advanced settings” --> "Use Adobe Flash Player".

      The MS Edge Team

    • Webm videos are supposedly supported in Edge, but only in some specific sites, like YouTube. This is a serious issue, Chrome and Firefox can load all the webms just fine, why Edge doesn’t?

    • Hi Jair,

      Edge supports VP9 and not VP8.  I am not certain about the history on this issue, however, I know that VP9 better suited for 4K streaming and other not to distant video requirements.

      If you find a VP9 video that doesn’t play please let us know as soon as possible.

      Regards,

      The MS Edge Team

    • I also wanted to mention the Edge User Voice site.  You can submit or upvote a feature request.

      https://wpdev.uservoice.com/forums/257854-microsoft-edge-developer

      The MS Edge Team

    • Microsoft Edge Team

      Changed Status to “By design”

    • Hi Jair,

      I will be moving this bug report to “Resolved” as support for VP8 is a feature request.

      Appreciate the support.

      The MS Edge Team

    • https://www.base-n.de/webm/VP9%20Sample.html

      This is a good example of Edge not playing VP9 videos.

      I will summit a uservoice petition for this issue. It’s a bit sad that Microsoft claims that Edge supports webm but it just a small part of it. Many sites are broken on Edge because

      • Users doesn’t know the difference between VP8 and VP9
      • Sites doesn’t care to encode uploaded videos using VP9
      • Somehow Edge doesn’t play VP9 videos (like in embedded webms on Reddit or 4chan)

      This isn’t an issue on Chrome and Firefox. On those browsers, webm "just works".

    You need to sign in to your Microsoft account to add a comment.

    Sign in