Asus router user interface problem

By design Issue #12099926

Details

Author
Salam R.
Created
May 23, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
15.15063
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Hi,

I have issue with Asus router user interface DSL-N55U_C1 and here is screenshot for it
http://imgur.com/a/2ipIm

I had reported this to Asus forums this is the link

http://vip.asus.com/forum/view.aspx?id=20170414224237172&board_id=11&model=DSL-N55U_C1&page=1&SLanguage=en-us

but still no answer from Asus

Tested older newer router firmware

Other browsers working fine

Thanks

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Steven K.”

  • Hi Salam,

    Can open open the debugger for this page? F-12 and go to the console tab and then reload the page.  Send a screenshot of the results.

    Most likely there is an error in the page, perhaps a blocked script or syntax error.  Edge added addition security features in the Creators Update.

    Let us know and thank you for the support,

    The MS Edge Team

  • Hi,

    I did as you mentioned and uploaded the screenshots to attachments

    Thanks for your support

  • Hi Salam,

    It was as I expected.  There are syntax errors and other issues with the html on router’s webpage, E.g. two html tags, incorrect doctype, etc.  Other browser’s are more lenient with respect to syntax errors.  This is meant to improve security; not just trying to make things not work.

    I would send Asus your screen captures and send them the link to this bug report.  :-D

    Also, if you are interested you could open the debugger and modify some of the CSS, etc to see if you can get the screen to look proper.  Also, if you can login to the router, perhaps update the html.

    I plan to close this as "working as designed".  Thanks again for the submission.

    The MS Edge Team

  • Hi,

    I will send it to send Link Asus again (Doing Double Agent Works) :D

    Thanks for your Support

  • Microsoft Edge Team

    Changed Status to “By design”

You need to sign in to your Microsoft account to add a comment.

Sign in