Edge browser can't find input with readonly="true" attribute

Won’t fix Issue #12105271

Details

Author
Chon N.
Created
May 23, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
15.15063
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

Using jQuery to find any element with readonly="true" elements doesn’t work in Edge version 40.15063.0.0 / 15.15063 but previously worked in version 38.14393.1066.0 / 14.14939. Here is a fiddle to produce the issue:
https://jsfiddle.net/ricco831/p3pwLrgj/

The alert should show 1, but in Edge, it alerts 0. The funny part is if you open dev tools (F12) and run it, it properly alerts 1, but close dev tools and it alerts 0 again.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Steven K.”

      Changed Assigned To to “Travis L.”

      Changed Assigned To from “Travis L.” to “Jose L.”

      Changed Status to “Confirmed”

      Changed Title from “Edge browser can't find input with readonly="true" attribute” to “Edge browser can't find input with readonly="true" attribute”

      Changed Title from “Edge browser can't find input with readonly="true" attribute” to “Edge browser can't find input with readonly="true" attribute”

      Changed Status from “Confirmed” to “Won’t fix”

    • Hi!

      We have made a decision to scope bug fixing on the current Edge product to critical security and reliability issues, and the minimum necessary to service in-market customers (RS4, RS5 and 19H1), in order to focus on high quality delivery of the new Edge based on open source.  I am resolving this bug Won’t Fix to let you know of this explicitly, instead of simply keeping the bug active. 

      Thanks,
      Zach

    You need to sign in to your Microsoft account to add a comment.

    Sign in