PDF open issues

Fixed Issue #12166637

Details

Author
Matthew A.
Created
May 29, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
40.15063
Reports
Reported by 29 people

Sign in to watch or report this issue.

Steps to reproduce

Some PDFs will not open in Edge 15. Tested on multiple machines and as soon as edge is updated to version 15 the pdfs will not open. This does not affect all pdfs it seems. It does effect pdfs stored in Amazon S3 e.g. https://s3.amazonaws.com/oneplussupport/OnePlus-3-USER_MANUAL.pdf

Similar issue observe on: https://e0b31d45f9c3e79bcfbd-3c98ed4ad25452fc7bf0a2bf32bcb03b.ssl.cf1.rackcdn.com/12_The%20Sentinel__A__.pdf

Similar issue observe on: https://cbc-drupal-assets.s3.amazonaws.com/MayBM_Guide.pdf?1HnwX6LvCav4aroLHY9XL1sxmSXrfdm9

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Venkat K.”

  • Yes, Same here S3 PDF’s are not opening in MS Edge browser
    Microsoft Edge 40.15063.0.0
    Microsoft EdgeHTML 15.15063

  • Spotted this too and it appears to be easily reproducible when Windows Defender SmartScreen is turned on in Edge (under the Advanced settings).

    Microsoft Edge 40.15063.0.0
    Microsoft EdgeHTML 15.15063

  • Edge can’t open some pdf file via mapped unit:

    1. cmd SUBST M: “d:\Program Files (x86)\MicroCap11”
    2. Edge can’t open file:///M:/DATA_LOC/OSC/RCO/rc_osc_hw.pdf
    3. Edge can open file:///D:/Program%20Files%20(x86)/MicroCap11/DATA_LOC/OSC/RCO/rc_osc_hw.pdf
    4. Edge can open file:///M:/DATA_LOC/OSC/RCO/RC-oscilator.pdf

    Tested on Microsoft Windows [Version 10.0.14393]
    Microsoft Edge 38.14393.1066.0
    Microsoft EdgeHTML 14.14393

  • Just updated some machines with the creators update and getting the same issue for pdf’s stored on AWS S3.

    Microsoft Edge 40.15063.0.0
    Microsoft EdgeHTML 15.15063

  • Microsoft Edge Team

    Changed Steps to Reproduce

    Changed Steps to Reproduce

    Changed Assigned To to “Manoj B.”

    Changed Status to “Confirmed”

  • Happening to me on https://s3-eu-west-1.amazonaws.com/files.pitchero.com/clubs/2112/VxjJXuVTTOA1f2o7KhqV_V3%20FRONT%20PAGE.pdf

    Using Microsoft Edge 40.15063.0.0 Microsoft EdgeHTML 15.15063

    It just hangs trying to download

  • I have just added https://s3-eu-west-1.amazonaws.com
    To Trusted Sites
    In
    Internet Properties – Security

    The PDF files now seem to download correctly in Edge and IE
    Not sure how you get to it via Edge but if you load IE select the Tools icon (top right) then select Internet options you can then select “Security” and “Trusted sites”.

    Strange ! but it seems to have solved my issue for the time being - hope it helps others

  • Also happens with buckets in eu-central-1 region. If the “fix” includes whitelisting URLs then also add: https://s3.eu-central-1.amazonaws.com/

  • Many thanks to John P. for his workaround, we just added https://s3.amazonaws.com/cdn.freshdesk.com to trusted sites and we can now access PDFs and other documents again with Edge and IE (Chrome is still working fine).

    I confirmed that the failure is with IE version 11.483.15063.0 and Edge version 40.15063.0.0. It was working fine before these versions.

    The workaround is fine, but all our customers will experience this problem (S3 Amazon is our Helpdesk Solutions’s attachments repository )…

  • THis problem appeared once before. Is there a timeline to fix this issue? A lot of developers are complaining about this affecting only customers that use Edge.

  • Same problem here - PDFs hosted on Amazon S3 embedded on web page.

    Works fine in IE Edge 14.
    Doesn’t work in IE Edge 15. Hangs at 'loading’.

  • Been having the same issue for months, any progress or a timeline like the previous user mentioned?

  • What’s the latest on this from Microsoft? We have a PHP script that serves PDF files as part of our product suite and since the update to Edge 15 PDFs either don’t load at all or take an age to load and render.

    I have run some packet tracing and observed that when requesting a PDF via a URL in the format:

    https://our-product-url.net/xxx/pdf.php?p=CAM140239

    The file content downloads multiple times. In one test, Edge sent the request off to the server 5 times and downloaded the whole file 5 times (3.25Mb). Each time Edge received an HTTP200.

  • Problem solved here!
    You can get PDFs opened again if you enable UAC on your System.
    Disabling UAC (as required for me) produces the described error.

    I already suspected that as I often had similar behaviours in the past.

    Greetings from Germany
    Günter

  • I have same problem with PDF blobs stored in azure blob storage (Edge just sits there with the wait animation, never loading the PDF). They would not open in Edge until I added https://*.blob.core.windows.net/ to my Trusted Sites list. Unfortunately this is not a good solution for my clients using Edge. IE11, Chrome, Firefox works w/o adding to Trusted Sites.

    Microsoft Edge 40.15063.674.0
    Microsoft EdgeHTML 15.15063

  • Looks like either setting “SmartScreen” to OFF or adding my blob storage URL to Trusted Sites resolves the problem.

  • Disabling UAC resulted in Edge being unable to open pdfs for me

    Enabling UAC resolved the issue

  • Microsoft Edge Team

    Changed Assigned To from “Manoj B.” to “Vyankatesh G.”

    Changed Status from “Confirmed” to “Fixed”

  • Hello,

    Thank you for providing this information about the issue. We are pleased to report this feature is fixed in Edge 16299 and is available in our current public build.

    Best Wishes,
    The MS Edge Team

  • Pardon me Vyankatesh G but what was the fix?

    We have many business users who are affected by this, if you’re going to say “enable UAC” that is not a solution for us - nor I suspect is it going to be for many others.

    Forgive me if I’m missing something but I do not see anywhere on this page that an official fix has been issued

  • Edge still can’t open a pdf file from drive letter mapped via subst command.

  • Nine months after being “fixed” this is still a problem. PDFs on a drive created by SUBST usually can’t be accessed by Edge.

  • Forgot to note it’s Microsoft Edge 42.17134.1.0 now.

You need to sign in to your Microsoft account to add a comment.

Sign in