XMLHttpRequest onprogress not fired for streaming response

Fixed Issue #12224510

Details

Author
Gautham K.
Created
Jun 3, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Standard affected
XMLHttpRequest Standard

Found in build #
40.15063
Fixed in build #
18.18218
Reports
Reported by 24 people

Sign in to watch or report this issue.

Steps to reproduce

Diagnostic data is available and has been analyzed automatically with the most relevant hints listed to detect the underlaying issue. Please find the insights listed below.

When an XHR request is made to a streaming API on Edge 15, the ‘onprogress’ callback is not called for the all the chunks. Previous versions of Edge till 14 and other browsers call the callback for each chunk received.Link to reproduce: http://jsbin.com/rijahud/edit?html,js,consoleMicrosoft Edge 40.15063.0.0Microsoft EdgeHTML 15.15063In the above example please note that onprogress callback should have been called for all chunks (till the line with id = 20) but that it is not the case.
Please see other feedbacks in userfeedback VSO for feedbacks that are tracked by this work item.

h3 {
color:#2f5496;
font-family:Segoe UI;
font-size:small;
padding-left:3%;
}

table {
font-size:small;
width:95%;
}

th, td {
font-size:small;
padding:5px;
}

td {
border:0.5px solid white;
}

th {
background-color:#8B8989;
color:white;
}

.feedback-leftcell {
width:20%;
color:#004d8b;
}

.feedback-row:hover {
background-color:#C4C4C4;
}

#feedback-banner, #feedback-footer {
background-color:#0078D7;
color:white;
width:100%;
}

#feedback-banner td, #feedback-footer td {
border:0;
font-size:larger;
padding:10px;
}

#feedbacksection-v5 {
font-family:Segoe UI;
border:5px solid #0078D7;
border-collapse:collapse;
}

#feedbackdetails-table, #feedbackanalysis-table, #feedbacklinks-table {
font-family:Calibri Light;
background-color:#f5f5f5;
}

                                                
        This Bug was created from feedback triage by Matt Durak
    

Report Details
                        Feedback Details
        Description
    
                Title
        Edge unable to upload to imgur

    
                Description
        Says uploading image but stuck on 0%. Works in Firefox. Repro's reliably, cab collected

    
                Area Path
        UIF\Microsoft Edge\Website issues
    
                [Feedback Hub](../6846480/) with any questions or feedback you have.

[END AUTOBUG CONTENT]

Attachments

0 attachments

    Comments and activity

    • Changed Steps to Reproduce

    • I’m also not seeing progress events for file uploads, they only seem by be called at the end of the XHR request…

    • Microsoft Edge Team

      Changed Assigned To to “James M.”

    • Hello,

      Thank you for providing this information about the issue. We are pleased to report this feature is fixed in Edge 16199 and is available in our latest Insider Preview build.

      Best Wishes,
      The MS Edge Team

    • I updated to Edge 41.16199.1000.0/EdgeHTML 15.16199 and the Progress Event still is NOT fired. You can reproduce it with uploading a big file here:
      http://jsfiddle.net/pthoty2e/

    • Hello,

      Thank you for providing this information about the issue. After thorough testing, we are unable to reproduce this problem in Edge 16195-16220. We can see the issue in Edge 15, but it appears to have been fixed in 16.

      Please try the repro again and if it still does not show the progress, run dxdiag (Windows key + r and type dxdiag, enter, then click Save all Information) and attach the txt file. Additionally, a screenshot of the upload in action may help us identify a difference between our repros.

      Best Wishes,
      The MS Edge Team

    • I’m using Microsoft Edge 41.16215.1000.0 / Microsoft EdgeHTML 15.16215 which is included in the latest Insider Preview.

      Is there a way to update EgdeHTML 15.x to EgdeHTML 16.x?

    • Hello,

      Looks like we are still calling 16215 part of 15.x, so 15.16215 is the latest. I am unable to repro the problem in 15.16195 through 15.16220.

      Best Wishes,
      The MS Edge Team

    • Hi,
      if you upload any file with this example, the “onprogress” Event still is only fired once: at 100%
      http://jsfiddle.net/pthoty2e/

      You can download the DxDiag here:
      https://mediacenter.email/download/50a2dc9c9caa47e48e95b1ba721/910f2dc4/8f072

      Best Regards,
      Henning

    • Hello,

      Thank you for the new repro sample. We see the problem and are investigating.

      Best Wishes,

      The MS Edge Team

    • Microsoft Edge Team

      Changed Status to “Confirmed”

      Changed Assigned To to “Venkat K.”

      Changed Assigned To from “Venkat K.” to “Scott W.”

    • I have been experiencing the issue with Microsoft EdgeHTML 15.15063.
      OnProgress event is fires only once - after the whole portion of data has been transferred.

    • Yes I am having the issue as well as lots of customers using edge. EdgeHtml: 15.15063 Edge: 40.15063.0.0

    • When?

      Any information about patch release?

    • Still having this with the fall creator update:
      Edge: 41.16299.15.0
      Edgehtml: 16.16299

    • I’m having this issue as well.

    • Issue still happening on latest Edge (16).

    • This issue affects CKEditor 5 too: https://github.com/ckeditor/ckeditor5-upload/issues/79

    • Not working in 17.17074

    • Can also confirm it’s not working in Edge 41.16299.15.0
      I hope this can be fixed soon, a lot of people are using Edge & we get complaints about it.

    • Microsoft Edge Team

      Changed Steps to Reproduce

      Changed Steps to Reproduce

    • Just ran into this myself. I was pulling my hair out for a good hour, thinking I was doing something wrong.

    • Still a problem in Microsoft Edge 41.16299.248.0 / Microsoft EdgeHTML 16.16299

    • Same here. I’m using the following to build an xhr for $.ajax:

      var xhr = new window.XMLHttpRequest();
      
      function on_progress(evt) {
        if (evt.lengthComputable) {  
          var percentComplete = evt.loaded / evt.total;
          progressbar_set_value(progressbar_, percentComplete)
          //Do something with upload progress
          console.log("XMLHttpRequest.upload progress", percentComplete)
        }
      }
      
      
      //Upload progress
      xhr.upload.addEventListener("progress", on_progress, false); 
      //Download progress (do we ever use this?)
      xhr.addEventListener("progress", on_progress, false); 
      

      Works fine in chrome and firefox, but in edge only the final event “XMLHttpRequest.upload progress 1” is fired.

    • Microsoft Edge 41.16299.15.0
      Microsoft EdgeHTML 16.16299

    • Still at problem in
      Microsoft Edge 42.17134.1.0
      Microsoft EdgeHTML 17.17134

    • Still a problem…I mean really this is just embarrassing. After constantly tormenting us to give Edge a try…

      Microsoft Edge 42.17134.1.0
      Microsoft EdgeHTML 17.17134

    • It really is the last straw that we are still having the problem

    • Microsoft Edge Team

      Changed Status from “Confirmed” to “In code review”

    • The same problem here:
      Microsoft Edge 42.17134.1.0
      Microsoft EdgeHTML 17.17134

    • Microsoft Edge Team

      Changed Status from “In code review” to “In progress”

    • @Scott: thanks in advance for solving the problem. It was frustrating to find a solution for Edge, without success. Please make a hotfix asap.

    • Microsoft Edge Team

      Changed Status from “In progress” to “Fixed”

    • Thank you everyone for reporting this issue and for your patience. I’m happy to report that this issue has been fixed and will be available in an upcoming Windows insider preview build.

    • Could anybody confirm when the fix for this issue is likely to be released ?

      I’m also having the issue with my edge :(
      Microsoft Edge 42.17134.1.0
      Microsoft EdgeHTML 17.17134

    • I’m very interested too when the fix will be released.

    • VERY VERY interested WHEN the bug will be fixed!!!

    • Microsoft Edge 42.17134.1.0
      Microsoft EdgeHTML 17.17134

      The problem is still present

    • I can see this wrong behavior also in:
      Microsoft Edge 42.17134.1.0
      Microsoft EdgeHTML 17.17134

      Available in the lates Win10 + Edge image from https://developer.microsoft.com/en-us/microsoft-edge/tools/vms/

    • It worked fine with the Edge available in the VM with Windows 10 (Build 10586.1176) and MS Edge (version 25.10586.672.0)

    • @Oscar: where did you get MS Edge in Version 25.10586.672.0? Here https://developer.microsoft.com/en-us/microsoft-edge/tools/vms/ is only version 17.17134 available. Where to test the the MS Edge (version 25.10586.672.0)? Thanks.

    • @Krzysztof: It was an old image available in the VMs site. Downloaded it on March 2016 if I’m not wrong. I probably can provide the VirtualBox .ova file if needed.
      Here an screenshot of the About info in MS Edge
      https://pasteboard.co/HGHS5Oz.png

    • @Oscar: thank you, this is a old version from 2016:
      Microsoft Edge 25.10586.672.0
      Microsoft EdgeHTML 13.10586

      The latest version of MS Edge is:
      Microsoft Edge 42.17134.1.0
      Microsoft EdgeHTML 17.17134

      And the new release with the fixed bug should be:
      Microsoft Edge ???
      Microsoft EdgeHTML 18.18218

      You tested with old version from 2016 and it is not relevant.

      @Everybody and @MicrosoftTeam: when will the fix be available and in which version of Windows can the fix be tested? Urgent!

    • @Krzysztof: Yes, I knew I was testing it with a super old version. I just wanted to point out a version where it worked as expected so the guys at Microsoft Team could take a look and check what they changed to make it fail.

    • The issue was declared as FIXED and available in version 18.18218.

      @Everybody and @MicrosoftTeam: when will the fix be available and in which version of Windows can the fix be tested? Urgent!

    You need to sign in to your Microsoft account to add a comment.

    Sign in