Microsoft Edge Driver keeps throwing "Not Implemented" When running selenium tests

External Issue #12238249


Jun 5, 2017
This issue is public.
Found in
  • Microsoft Edge
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce


I’m working with automated tests and I’m trying to set up selenium grid for running tests in multiple environments.

I’ve successfully ran tests with chrome driver in Mac OS X 10.11 and Windows10.

I’ve tried to run the tests locally with selenium standalone server,and when I run a test feature, with edge driver, the following message prompts on:

10:27:40.114 INFO - Done: [send keys to active: [1, 1, 1, 1]]
10:27:43.075 INFO - Executing: [fetching available log types])
10:27:43.106 WARN - Exception thrown
org.openqa.selenium.WebDriverException: Not implemented (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 31 milliseconds
Build info: version: '3.4.0', revision: 'unknown', time: 'unknown'
System info: host: 'DESKTOP-FBA3OPB', ip: '', 'Windows 10', os.arch: 'amd64', os.version: '10.0', java.version: '1.8.0_131'
Driver info: org.openqa.selenium.edge.EdgeDriver
Capabilities [{applicationCacheEnabled=true, pageLoadStrategy=normal, platform=ANY, acceptSslCerts=true, browserVersion=38.14393.1066.0, platformVersion=10, locationContextEnabled=true, webStorageEnabled=true, browserName=MicrosoftEdge, takesScreenshot=true, takesElementScreenshot=true, javascriptEnabled=true, platformName=windows}]
Session ID: 1C4384EA-0B3D-4C06-B0C6-9C3773C6C7D6
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
        at java.lang.reflect.Constructor.newInstance(Unknown Source)
        at org.openqa.selenium.remote.ErrorHandler.createThrowable(
        at org.openqa.selenium.remote.ErrorHandler.throwIfResponseFailed(
        at org.openqa.selenium.remote.RemoteWebDriver.execute(
        at org.openqa.selenium.remote.RemoteWebDriver.execute(
        at org.openqa.selenium.remote.RemoteExecuteMethod.execute(
        at org.openqa.selenium.remote.RemoteLogs.getAvailableLogTypes(
        at Source)
        at org.openqa.selenium.remote.server.DefaultSession$
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$ Source)
        at Source)
10:27:43.106 WARN - Exception: Not implemented (WARNING: The server did not provide any stacktrace information)

This specific case I was trying to run the following command (see setValue for more information):

browser.setValue('(//input[contains(@class, "pin")][1])[1]',1);

Another statement where it sometimes fail is:

16:10:06.939 INFO - Executing: [find elements: By.xpath: //div[contains(@class, "content") and contains(@class, "pins")]])
16:10:06.954 INFO - Done: [find elements: By.xpath: //div[contains(@class, "content") and contains(@class, "pins")]]
16:10:07.126 INFO - Executing: [fetching available log types])
16:10:07.251 WARN - Exception thrown
org.openqa.selenium.WebDriverException: Not implemented (WARNING: The server did not provide any stacktrace information)
driver.waitForExist('//div[contains(@class, "content") and contains(@class, "pins")]', 2000);

Note that this does not always happen on the same selenium command, occasionally the tests run successfully. Not sure What I’m missing here, should be a problem on the webdriver since I’ve tested with both selenium standalone and grid and this is running on other browsers like chrome and firefox (gecko driver).

Selenium standalone : 3.4.0
Windows : 10
Microsoft Edge: : 38.14393.1066.0
Microsoft EdgeHTML : 14.14393

Microsoft WebDriver:
Release 14393
Version: 3.14393

This should not be relevant but I’m using webdriverio and cucumber to run these tests (I leave the stacktrace):

1) User (full) sets up pin:
running MicrosoftEdge


0 attachments

    Comments and activity

    • Changed Steps to Reproduce

    • Microsoft Edge Team

      Changed Assigned To to “Steven K.”

    • Hi,

      It appears to be a logging configuration issue.  What type of logging do you have enabled for WebDriver?
        Did you set the same driver capabilities for the chrome testing?

      From the two stack traces you sent, it appears the exception is being thrown during the method call to "RemoteLogs.getAvailableLogTypes(

      Here is what I am referring to in the first stack trace:

       at org.openqa.selenium.remote.RemoteLogs.getAvailableLogTypes(
      In the log output you sent (not certain from which log this is) it appears to show the find by XPath is successful. However, the query for log types is failing.

      16:10:06.954 INFO - Done: [find elements: By.xpath: //div[contains(@class, “content”) and contains(@class, “pins”)]]
      16:10:07.126 INFO - Executing: [fetching available log types])
      16:10:07.251 WARN - Exception thrown

      Hope this helps,


    • Hello,

      Using webdriverio we have an after hook (more here) I have configured it to log with logType browser, this is working in other browsers (chrome/Mac OS X).

      The snippet I’m using:

      // Gets executed after all tests are done. You still have access to all global variables from
      // the test.
      after: function (result, capabilities, specs) {

      I’m getting a session timeout in EDGE, I added this line in order to understand what is causing it, is there another way to see this log? Or should I open an issue explaining the scenario where tests are throwing 10:50:13.156 WARN - Exception: Session ID is null. Using WebDriver after calling quit()??

    • Hi,

      Just checked and I can see log and log types are not supported, I’m still getting a session delete and therefore the session ID is lost (please see comment above) and I’m a little bit lost, is there anything (in terms of logs) I can configure in order to find what it is causing this?


    • Can you share a minimal version that I can run to repo this?  Also, a version for chrome?

      Thanks for the link.  I should have checked that first.  :-/

      I will also run some testing to see what impact the lack of log support has as compared to a driver that does have this support.


    • Forgot to answer your other question.  I think you actually found the answer yourself, I.e. Edge does not support those WebDriver API calls and so when the request is made for getting the available log types the “Not implemented” exception is being thrown.

      I have been using testNG’s Reporter class.



      public void
      ( “Message”
      , true

      public void
      launchBrowser() throws
      Exception {
      .println(“launching Microsoft Edge browser”
      , driverPath
      = new
      (“Browser Opened”

      public void
      openEdgeBrowser() throws
      Exception {

      Thanks again for the continuing to push on this question/issue. I will investigate further.

    • Hi,

      I wanted to give an update on WebDriver logging with Edge.

      First, the JsonWireProtocol as defined by SeleniumHQ is deprecated.  It was in this protocol specification that the logging capabilities for the WebDriver session were defined.

      “Status: OBSOLETE See current W3C specification for WebDriver”

      The idea was to allow the client test to request a session with logging enabled for the various “entities” in the WebDriver test path.  The available “entities” were:

      • Client: the language/framework used for running the testing.
      • Server: the machine where the driver would be running.
      • Driver: the actual implementation of the WebDriver instance being used.  E.g., Microsoft WebDriver for Edge, ChromeDriver for Chrome, etc.
      • Browser: the User Agent/Browser receiving the testing/JsonWireProtocol commands from the WebDriver instance.

      The current WebDriver Recommendation does not have logging capabilities defined.  I do not know why these were dropped.  Perhaps these logs were thought best collected at each source?  E.g., look in WebDriver’s console or the Clients test code output.

      The example I gave of using TestNG as a workaround only addressed the client side logging.

      Supporting the various logging is under consideration, however, it is optional and would be browser specific due to the WebDriver Recommendation not defining logging on any of the four “entities” mentioned previously.

      I am sure you have already worked out way to get the logging you needed and you were right about the Microsoft WebDriver not supporting these JsonWireProtocol commands.

      Appreciate this submission and the support,


    • Microsoft Edge Team

      Changed Assigned To to “”

      Changed Status to “External”

    • We currently don’t support logging via the JSON Wire Protocol however we are tracking this feature request internally.

    • This issue has been resolved External. This means this issue may require a new feature to be implemented or other work that is more significant than a typical bug. You may be able to find more information on this issue by searching for related features on and

    You need to sign in to your Microsoft account to add a comment.

    Sign in