IE - First Ajax request waiting for a longer period of time

Won’t fix Issue #12239135

Details

Author
Karthick B.
Created
Jun 5, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
  • Internet Explorer
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Hello All,

We have developed an Single Page Application(SPA) using angularjs. As this is an SPA, we have used client side routing for navigating between pages. In the application there is a particular section in which there 25+ ajax calls happening. Now, the issue is whenever a user navigates to this page anywhere from the application, It takes 25 seconds on an average to load the page in IE whereas in chrome and other browsers it works properly.

Upon investigating, we found that in IE whenever navigating to this page the first service request is waiting for 15+ seconds. If this service’s responded correctly then the subsequent request’s response are very fast and everything works properly.

Now, Could any please tell why IE is taking time to hit the server for the first request?

I have attached screenshot for your reference. In the screenshot you can clearly see the start duration of the request is approximately 15 seconds.

Please help us to resolve this issue as this is a business critical issue.

Note: We are using https connection for our request and response.

Attachments

1 attachment

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “James M.”

  • Hello,

    Thank you for providing your feedback on IE11. We are not accepting feedback on Internet Explorer through this portal any longer (unless security related). We welcome any feedback you have on Microsoft Edge through this website.

    If this is blocking enterprise deployment, please follow the CSS escalation process to engage MS support (GES, General Escalation Service) and file a servicing request.

    Support URL: https://support.microsoft.com/en-us/gp/support-options-for-business

    Best Wishes,
    The MS Edge Team

  • Microsoft Edge Team

    Changed Status to “Won’t fix”

You need to sign in to your Microsoft account to add a comment.

Sign in