Selenium 3.4.0 doesn't click "span" on Edge 14.14393

Fixed Issue #12306419

Details

Author
Tinh D.
Created
Jun 12, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

I execute xpath like //span[contains(@Class,’pfandobjekt’)].
This work on IE Firefox and Chrome browser. ( latest version)
But with Edge, I can’t
Microsoft Edge 38.14393.1066.0
Microsoft EdgeHTML 14.14393
Selenium 3.4.0

Please help me check.

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Status to “Fixed”

  • Thank you for submitting this issue. This was logged against a very old build of Windows and Microsoft Edge. I am not able to repro this issue on the most recent version. Resolving as fixed.

  • Hi John,
    Thanks for your feedback. But I tried to check it again.
    When i use “Enabled” -> I got True. But when Clicking I got the exception "OpenQA.Selenium.ElementNotVisibleException ".

    I search and tried with solution refer link “https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/9706328/” But it doesn’t work.

    Please refer attachment for more detail.

  • Changed Status from “Fixed”

  • Microsoft Edge Team

    Changed Assigned To to “Steven K.”

  • Hi Tinh,

    I recommend you try using an explicit wait to require the driver to not fail prematurely.  In your case, you should be able to use the same “By.Xpath(//a…” By selector.

    http://www.seleniumhq.org/docs/04_webdriver_advanced.jsp

    WebElement myElementWaiter = (new
    WebDriverWait(driver
    , 10
    ))
    .until(ExpectedConditions
    .presenceOfElementLocated
    (By.xpath
    (“<fill in your xpath String>”
    )));
    myElementWaiter.click();

    Hope this helps,
    The MS Edge Team

  • Hi Steven,
    Thanks for your support.
    I tried your idea but the same issue happen.
    It can pass WebdriverWait but can’t click element.

  • Do you need an ng-click directive or an “input” element type for Angular?  I.e. how do you tell Angular this is a clickable item?  I believe Angular vs Angular2 changed this behavior.

    https://forum.ionicframework.com/t/ng-click-wont-work-with-anything-but-a-button-if-inside-a-form/7846

    I found this wrapper library for using Java WebDriver with Angular apps.

    https://github.com/paul-hammant/ngWebDriver

    Sorry, I am not more help,

    Steve

  • I also saw others having issues because the app bindings were not correct.  Are any other elements clickable?  Just trying to be complete.  I am guessing this is not the issue.

  • Hi Steven,
    At the moment, I can input element type when use selenium on Edge.
    But I can’t click or select because control enabled but not displayed.

    I don’t know why, I continue to research it.

  • Hi Steven,
    I can click on it. I use javascriptClick :

    public void JavaScriptClick(IWebElement element)
    {
    IJavaScriptExecutor executor = (IJavaScriptExecutor)driver;
    executor.ExecuteScript("arguments[0].click();", element);
    }

    But I check css my app. the display = block. Maybe, this is issue of selenium. :)

  • Hi Tinh,

    Thank you for the update.

    Perhaps you could pause the test case to debug the test while the browser is open?

    I found an article talking about a case where the injected JS works when the WebDriver version does not.

    http://darrellgrainger.blogspot.com/2013/05/why-using-javascriptexecutor-in.html

  • Microsoft Edge Team

    Changed Status to “Fixed”

You need to sign in to your Microsoft account to add a comment.

Sign in