Font renders with malformed glyphs when using .woff and .woff2

Not reproducible Issue #12382494

Details

Author
Curtis P.
Created
Jun 18, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
  • Chrome
  • Firefox
Found in build #
15.15063
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Edge seems to break when rendering a particular font I am working with, CF Oak Island (commercial with full glyphset). Whilst some glyphs render correctly, the majority of them do not - simply deciding that they’re going to render weird square sections of the glyph, and not the others. The affected glyphs are consistent - restarting the browser makes no difference to which letters seem to be corrupted. The functionality is there in all other OSes that I have tried so far just fine - I’ve even got the font installed locally, and it doesn’t seem to work. All browsers I have tried so far on Windows 10 seem to have this bug.

I have tried with both .woff and .woff2 formats, both seem to exhibit this bug.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Steven K.”

    • Hi,

      Can you provide a repro for this?  I would like to see how you are defining your ‘font-family’ properties on your webpage.

      Do you know what unicode-range or ranges this specific font uses?

      https://drafts.csswg.org/css-fonts/#font-family-prop

      Also, can you could provide a link to where you acquired this font?

      Appreciate the support,

      The MS Edge Team

    • Microsoft Edge Team

      Changed Status to “Not reproducible”

    You need to sign in to your Microsoft account to add a comment.

    Sign in