Page- and search suggestions does not work and instead Edge uses 30% cpu for Norwegian language after installing Creators Update

Fixed Issue #12458916

Details

Author
Jon B.
Created
Jun 23, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
15.15063
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

After installing Creators Update and when running with Norwegian Language for Windows, page- and search suggestions does not work in Edge. Instead one of the Microsoft Edge background processes starts using 30% cpu. This continues until all Edge windows are closed. This problem has been observed on multiple computers. All with Norwegian Language. If we change the language to English US, the problem disappears.

Steps to reproduce:

  1. Select Norwegian (Bokmål) as Windows language.
  2. Open Edge browser.
  3. Type any letter in the address bar.

Observe in the Task Manager that one of Microsoft Edge processes consumes 30% cpu.

Attachments

1 attachment

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “James M.”

  • Hello,

    Thank you for providing this information about the issue. After thorough testing, we are unable to reproduce this problem in Edge. Please try disabling any browser extensions and restarting Edge to see if this fixes the problem. If not, please run dxdiag (Windows key + r and type dxdiag, enter, then click Save all Information) and attach the txt file.

    Best Wishes,
    The MS Edge Team

  • Hi,

    This problem is constant on all our office computers. Also on our personal computers outside of Office. Other people in Norway have reported the same issue:
    https://answers.microsoft.com/en-us/windows/forum/windows_10-performance/high-cpu-on-edge-with-different-languagepack/b79d2109-97d9-4bef-840a-2daf2895ab11
    You need to have the Norwegian language pack installed and set as display language.

    Jon

  • Wanted to say our company has the same issue, it happens consistently on all computers. We have put the Creators Update on hold because of this. It does not matter how Windows is installed, manually from VL ISO or deployed from MDT. We use Norwegian VL media, Enterprise edition and Dell computers. I seem to remember the issue didn’t show up on a fresh unpatched Windows 1607 install, but after some Windows updates it was back. Changing Search provider or “prediction while typing” doesn’t matter. No Edge extensions. The prediction thing for norwegian also does not seem to be working in contrast to english language, maybe this is related to the problem.

  • Typo, i meant unpatched Windows 1703 install, not 1607.

  • Microsoft Edge Team

    Changed Status to “Fixed”

  • Hello,

    Thank you for providing this information about the issue. We have confirmed the problem, and we are working on a solution for a future build of Edge. We are presently tracking this issue as a duplicate of an existing internal bug report. We look forward to additional feedback you may have on how we can improve Microsoft Edge.

    Best Wishes,
    The MS Edge Team

You need to sign in to your Microsoft account to add a comment.

Sign in