Submit form using webdriver fails on Edge 15

Fixed, not yet flighted Issue #12658469

Details

Author
Jesse C.
Created
Jul 6, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

Simplifying the repro steps for this issue. What it boils down to is this:
If you click ".submit()" on the form element itself, we fail to submit due to an elementnotfound exception. All other drivers work in this case.

This code will repro:

            _driver.Navigate().GoToUrl(“http://ie-snap/scratchtests/johnjan/bugs/form.htm”);
            Thread.Sleep(2000);
            _driver.FindElementById(“inputelement”).Submit(); // does not fail
            Thread.Sleep(2000);
            _driver.FindElementById(“formelement”).Submit(); // fails

(the html of the page is simply this:
<form id="formelement">
    <input id="inputelement" type="text">
</form>
)

Attachments

0 attachments

    Comments and activity

    • Changed Steps to Reproduce

    • Microsoft Edge Team

      Changed Assigned To to “Steven K.”

    • Hi,

      Can you provide a repro for this?  For example, the website you tested against and your webDriver code?

      From the exception logs it is showing that there is a problem locating the requested element:

      5:9:4:47 REQUEST [2017-7-6 5:9:4:47] POST /session/ef5a5fc6361df3ecef251af05ca384d5f83290ff/element/8/submit {} 2017-7-6 5:9:4:461 RESPONSE {"state":"no such element","sessionId":"ef5a5fc6361df3ecef251af05ca384d5f83290ff","hCode":31671811,"value":{"additionalInformation":"\nDriver info: 

      Have you tried selecting the form button and then using the click() method?  Both submit() on a form element and click() on a form button should work:

      https://stackoverflow.com/questions/17530104/selenium-webdriver-submit-vs-click

      Steve

    • Microsoft Edge Team

      Changed Status to “Confirmed”

      Changed Assigned To to “Mike J.”

      Changed Assigned To from “Mike J.” to “John J.”

      Changed Status from “Confirmed”

      Changed Steps to Reproduce

      Changed Assigned To from “John J.” to “Mustapha J.”

      Changed Status to “Confirmed”

    • Steven K., oh my god, have you tried to test edge driver before writing here such an absurd??

      Webdriver’s submit() doesn’t work with damn Edge.

      Go to any site with form, lets say github.com
      and do something like
      findElements(By.xpath("//form[contains(@class,’signup’)]")).get(0).submit()

      Oh, I forgot, this crap browser doesn’t work with xpaths properly.
      Try something like
      findElements(By.xpath("//form[contains(boolean(@class,’signup’))]")).get(0).submit()

    • I concur this issue. I recently copied a test script that was working fine with a different browser’s driver. After fixing all the Xpaths (damn it to hell) on the first page I get the same situation: MicrosoftWebDriver does not properly handle WebElement submit() when the WebElement in question is a form. Always throws "The element is not in a form".

      No duh! It is the form.

    • @David W., was that a Python reference?!  If it was, you made my day.  Either way, I took it as one.  I laughed about that a couple times this weekend.

    • Microsoft Edge Team

      Changed Status from “Confirmed” to “Fixed”

      Changed Status from “Fixed” to “Fixed, not yet flighted”

    • Hello,

      Thank you for providing this information about the issue. We are pleased to report this feature is fixed in Edge and will be available in an upcoming insider build.

      Best Wishes,
      The MS Edge Team

    You need to sign in to your Microsoft account to add a comment.

    Sign in