(Webrtc) VP8 NACK not working

Fixed Issue #12919339

Details

Author
Francesco D.
Created
Jul 25, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
40.15063
Reports
Reported by 10 people

Sign in to watch or report this issue.

Steps to reproduce

Hi guys,
I’m currently testing Edge 40.15063.0.0 with my implementation of a webrtc server.
I noticed that I never receive a nack.
So i tried an open p2p demo and I noticed that nack are negotiated:
a=rtpmap:96 VP8/90000
a=rtcp-fb:96 nack
a=rtcp-fb:96 nack pli
a=rtcp-fb:96 goog-remb
but edge never send one on packet loss.
It only send pli, but this causes lots of interruption during video playback.

It can be tested joining https://appr.tc/r/edgenacktest?vsc=vp8 in two different pcs and inspecting chrome’s chrome://webrtc-internals.

If you manage to generate packet lost on chrome’s upload, we will receive only plis from edge.

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Shijun S.”

    Changed Status to “Confirmed”

  • Also REMBS are not sent with a proper ssrc.

  • Microsoft Edge Team

    Changed Assigned To from “Shijun S.” to “Frank L.”

    Changed Assigned To from “Frank L.” to “Shijun S.”

    Changed Status from “Confirmed” to “Fixed”

  • We made a fix to this in our local build.  It will propagate to public Insider releases in the next few weeks.

    If any further question on the issue, please feel free to reach out to us directly.

    All the Best,

    Shijun Sun (shijuns@microsoft.com), and 

    Bernard Aboba (bernarda@microsoft.com)

  • Was this released with Windows 10’s Fall Creators Update, i.e build 16299?

  • Any news? seems like it hasn’t be released yet. since it’s fixed, can we please have a timeline? this bug prevents edge to works with latest videoconference solutions

  • I may be wrong, but from my testing it would appear that NACKs are broken with H264 as well

  • Please try the latest Windows 10 Insider build, there are 2 more fixes in this area.

    Regards,
    Frank Li

  • I have tested in Microsoft Edge 42.17134.1.0 (EdgeHTML 17.17134) and still not see any NACK requests sent by edge. Looks like edge send PLI right now after lost one packet.

    Maybe I do something in wrong way ? Is NACK require RTX in edge ?

    I configured stream parameters as:
    var streamParams = {
    codecs: [],
    encodings: [],
    fecMechanisms: [],
    headerExtensions: [],
    rtcp: {cname: "", compound: false, ssrc: 127}
    };

        var vc = RTCRtpReceiver.getCapabilities('video').codecs;
        for(i=0; i

You need to sign in to your Microsoft account to add a comment.

Sign in