Edge browser crashes on launch when IBM Trusteer Rapport is running

Duplicate Issue #13245267 • See Issue #13328205


John F.
Aug 14, 2017
This issue is public.
Found in
  • Microsoft Edge
See progress on Bug #13328205
Found in build #
Reported by 12 people

Sign in to watch or report this issue.

Steps to reproduce

Since upgrading to Windows 10 Version 1703, the Edge browser has failed to start properly. If the Trusteer Rapport application is running then Edge consistently starts to open but immediately shuts down with the following error report. If I stop the Trusteer Rapport application, then Edge starts normally.

Faulting application name: MicrosoftEdge.exe, version: 11.0.15063.447, time stamp: 0x5948acf2
Faulting module name: EMODEL.dll, version: 11.0.15063.540, time stamp: 0xc81a45cc
Exception code: 0xc0000409
Fault offset: 0x00000000000eb3bc
Faulting process id: 0x222c
Faulting application start time: 0x01d314e751aa1a18
Faulting application path: C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\MicrosoftEdge.exe
Faulting module path: C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\EMODEL.dll
Report Id: 40c15f93-70fc-46c0-8045-50330eb6ea3c
Faulting package full name: Microsoft.MicrosoftEdge_40.15063.0.0_neutral__8wekyb3d8bbwe
Faulting package-relative application ID: MicrosoftEdge


0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Steven K.”

      Changed Assigned To to “Lee H.”

      Changed Assigned To to “Sebastian P.”

      Changed Assigned To from “Sebastian P.” to “Matt R.”

      Changed Status to “Confirmed”

      Changed Title from “Edge Browser with IBM Trusteer Rapport” to “Edge browser crashes on launch when IBM Trusteer Rapport is running”

    • The Application Error event seems to be preceded on each occasion by up to a dozen DistributedCOM events:
      The server Microsoft.MicrosoftEdge_40.15063.0.0_neutral__8wekyb3d8bbwe!ContentProcess did not register with DCOM within the required timeout.

    • Edge browser crashes on launch when IBM Trusteer Rapport is running

    • Edge browser is very slow after the windows update today

    • Received this from IBM Trusteer Support:

      Please be advised that IBM Trusteer Rapport currently does not support Edge 15.
      To check your browser’s version: Open Microsoft Edge, select the 3 dots (‘More’) in the upper-right corner and then select Settings.
      Scroll down and look for your version under 'Microsoft EdgeHTML’.

      The issue is currently being investigated by our company experts and we expect it to be resolved in a future release of Rapport.
      Unfortunately, at the current stage of the investigation we do not have a definitive time frame for resolution.

      As a temporary workaround, you may use Internet Explorer, Google Chrome or Firefox for online banking.
      To locate and open Internet Explorer in Windows 10: Click Start (Windows logo) > All Apps > Windows Accessories > Internet Explorer

      In addition, should you decide not to use the aforementioned browsers for online banking, we advise you to disable Rapport’s Early Browser Protection.
      Please note that this is not a permanent solution, and once this Rapport feature is deactivated you are not fully protected.

      To disable Rapport’s Early Browser Protection:

      1. Open Rapport’s Console (Press the Windows logo key+ S to open Search >Type ‘Trusteer’ > Click ‘Trusteer Endpoint Protection Console’)
      2. Advance to the next page by clicking on the green arrow at the bottom-right.
      3. Under ‘Security Policy’ at the top left corner, click on 'Edit Policy’.
      4. Enter the letters as they are shown in the image and click OK.
      5. Locate ‘Early Browser Protection’ and select ‘Never’ in the drop-down menu.
      6. Click ‘Save’ and reboot your computer.
      7. Check if the issue is resolved.
    • The “advice” from IBM Trusteer Rapport seems to be a mealy-mouthed avoidance of the problem. It is not simply that that “IBM Trusteer Rapport currently does not support Edge 15” - Trusteer Rapport actively interferes with Edge, so that Edge cannot start.

      As outsiders, we cannot guess what is going on here. But it’s extraordinary that programs sporting the prestige brand-names IBM and Microsoft are so poorly designed that they cannot co-exist. Especially when the application is supposed to enhance security.

    • “As a temporary workaround, you may use Internet Explorer, Google Chrome or Firefox for online banking.
      To locate and open Internet Explorer in Windows 10: Click Start (Windows logo) > All Apps > Windows Accessories > Internet Explorer”

      To do this you would need to leave Rapport’s Early Browser Protection enabled, which means Edge would be unusable. I would hardly call this a workaround. Edge seems so much better since the 1703 upgrade that it would be a shame not to use it.

    • I’ve spent about 6 hours over the last few days to resolve the Edge shutdown problem. Uninstalling Trusteer was a minor suggestion in all the online advice I sought for a resolution. Edge worked immediately after uninstalling Trusteer. Trusteer is installed on my other computer and Edge works O.K. This is a 32 bit machine whereas the machine with the problem is 64 bit. Is that a clue to the problem?

    • Could be. My machine is 64 bit and Edge also works after switch off early browser protection. If anyone has an insight on this I’d be interested to hear it.

    • My concern is who’s taking ownership of the problem, Microsoft or IBM, and can anyone give an estimate for fixing it,
      P.S. I’m also using 64 bit.

    • I have reinstalled Trusteer using Edge browser and both are working together now. I will give it a few days to see if it remains stable. Could this be the solution? Uninstall Trusteer to get Edge up and running, then using Edge reinstall Trusteer.

    • Robin W. - can you let us now which version of Trusteer has now been installed? I tried your method unsuccessfully a few days ago - the version then installed was:
      IBM Security Trusteer Rapport Emerald Build 1804.134
      Configuration file: 4406815
      (My version currently claims that there are no pending updates)

    • Microsoft Edge Team

      Changed Status from “Confirmed” to “Duplicate”

    • I have the latest version of Trusteer on both of my machines 1804.134, also with no further updates reported. I tried to break Edge by uninstalling and reinstalling Trusteer on both my 32bit machine and 64bit again. Edge remains working on both. Trusteer offer two methods of downloading from sources, that is, from “your bank” and also for three particular browsers. I downloaded from my bank. Whether that makes any difference - I don’t know. It’s an odd problem that seems to have multiple resolutions. It seems only one method works, or not at all, according to unknown computer configuration criteria and it may be the reason Microsoft/IBM are slow in coming forward with a fix.
      Message to Matt R… What is meant by the change of Status from “Confirmed to Duplicate?” Please forgive me if it is obvious to most.

    • Having upgraded to Windows 10 1703 with Edge not functioning and then disabling Trusteer Rapport, Windows 10 in general and Edge in particular is working much more smoothly. I’m now wondering how much of this is due to Trusteer being disabled. Perhaps Robin W. you have some insight into this?

    • I probably tried most suggestions to stop Edge from self-closing. It was only when I uninstalled Trusteer did Edge behave itself. Re-installing Trusteer from scratch worked for me. Edge appears stable, but it is early days and time will tell. Other than that, I’m afraid, I have no idea why uninstalling Trusteer and then re-installing it corrected the problem with Edge on my machine. Could it be that trying one or more previous suggestions changed a configuration somewhere within a file(s) and that allowed Edge and a newly installed Trusteer to co-exist? That’s the best I can offer - sorry.

    • Robin W. - I have now done a “deeper” Uninstall of Trusteer (including removal of visible Trusteer files, and a Restart). [Even a “deep” Uninstall seems to leave enough stuff for Trusteer to know it’s been here before!]

      Then I re-installed Trusteer, including a Restart after checking that Trusteer was installed. All this extra effort means that, like you, I now have Edge running OK, and Trusteer running OK. The Configuration File has been changed, but the Version is the same (1804.134).

      BUT I strongly suspect that Trusteer is not attempting to protect Edge any more (Trusteer have specifically said that Microsoft Edge 15 is not supported). The nasty little focus-stealing popup does not appear, as it used to do before Windows 10 1703. So I must remember to use IE for my banking logins.

    • I unistalled Trusteer (rapport) using chrome. Edge then worked OK so I went on to my bank web site on Edge and downloaded Rapport from the bank site. Edge has kept working since and I have Edge 15.

    • Hello,

      Thank you for providing this information about the issue. We have confirmed the problem, and we are working on a solution for a future build of Edge. We are presently tracking this issue as a duplicate of an existing internal bug report. We look forward to additional feedback you may have on how we can improve Microsoft Edge.

      Best Wishes,
      The MS Edge Team

    • I followed Brian R’s advice to uninstall Trusteer Rapport (but from Control Centre.) Then used working Edge to download the windows copy of Trusteer and install it. Now Edge works fine. 64 bit machine. Thanks Brian R for this working solution.

    • Almost same as Brian R./RobD. for me. I’d raised a ticket with Trusteer (before Brian R’s comment appeared), instructions as given to me below including the full removal of remnants of the older version. One issue I had was in deleting a particular file that always seemed to be in use, even after a reboot. A solution to that was to reboot in some other mode (I chose the command prompt, but Safe Mode would have been easier) and delete it then.

      From IBM Trusteer Support:

      1. Uninstall Rapport using our Safe Uninstall Utility. Please download and run our Safe Uninstall Utility from the following link in order to remove Rapport from your PC:

      Instructions for using our removal utility can be found here:

      Make sure to reboot your PC to complete the uninstall process.

      1. Please confirm Rapport has been completely removed using the instructions in the following link: http://www.trusteer.com/support/remove-rapport-folders

      Make sure you remove all of Rapport’s folders as required. If some folders remain, you might experience trouble when trying to re-install Rapport.

      1. Once the folders are deleted, please download Rapport’s updated version and check if the issue you have been experiencing is resolved.

      You can download Rapport’s latest version here: http://www.trusteer.com/support/rapport-installation-links

    • Having logged this issue, I waited for events to develop! So I have just done what Anonymous suggested above and Lo and Behold, Edge no longer exits immediately after launch. I then found the reply from Trusteer in my spam folder that told me the same info as above. What Trusteer also told me was "However, please be advised that Microsoft Edge 15 is still not supported by Rapport and you will not be protected while using it to conduct your online banking". This is borne out by the absence of the annoying little pop-up we used to get with Edge when Trusteer was protecting the passwords.

    • Now October and have just come across this problem. Also have Rapport and upgraded win 10 to 1703 today and now Edge browser not working. After all these weeks still no fix?

    • Hey Colin B.
      Bizarre isn’t it? Guess this problem is a lower priority to others.
      I like using Edge and I like the comfort that Trusteer provides but . . .

    • Oct 20th 2017 Just had to remove IBM’s trusteer rapport software to allow Edge to start. I needed support from Microsoft on a Fall Creators Update failure. It starts Edge as part of the support process but it could not and I had to abort the support process. I have W10 64 Home version 1703.
      Delete rapport and Edge works fine. This is a piss poor IBM!

    • With the update to 1703, Edge 15 stopped working. Some of the “fixes” found online (including Microsoft site) caused more problems than it fixed. (eg: broke my Office 2017). The ONLY thing that resolved the problem was the removal of Trusteer Endpoint, & the version I have is 1804.161. My system is the same as John’s - W10 64, & the resolution was the same. I fully agree with your comment John on IBM!
      I do not intend to re-install Trusteer until such time I see a FIX posted, either by Microsoft or IBM.

    • Bearing in mind that IBM managed to stop Trusteer working on Firefox(for a month) and on Chrome(still not working) and do not seem capable of writing some simple coding to get Edge running with Trusteer (since early August) one does wonder how good their program is at protecting bank sites.

    • Not working for me on Chrome either, even though it says it’s enabled. Works on IE 11 though. What is going on?

    • At last my mystery is solved by finding a random reply that led me here. Yes turn Rapport off and Edge works. So IBM and MS, two of the biggest names in IT, cannot work together on a banking security issue! What a surprise. Both run by feature led sales teams. Both probably blaming the other.
      Right can someone from MS or IBM explain the exact technical problem or are they still just bouncing this around their support process with absolutely no priority. Of course it may be so dangerous they cannot talk about it!
      One decent programmer/analyst/systems engineer would trace this down and identify the problems within days probably. It may take longer to fix.
      BTW my 250ms key stroke delay has also now gone in IE! Now there is another clue for the missing IT expert.
      If this was my IT team when I worked for a living I would have been sacked! If you want real peace of mind it looks like avoid MS and IBM and especially do not expect them to work together.
      What about cyber security going forward? Any minor problem can be a potential major security breach. All those ignored compilation warnings are all potential breaches. Just because a feature you test works is no excuse for ignoring a bug that may be jeopardizing Trusteer on other browsers.

    • Edge browser & Rapport - has anyone found a fix, yet? I’ve not been able to use Edge since since September, unless I uninstall Rapport. Chrome & Rapport works fine, at least for now, but might now after another Chrome update.

    • The process described in the IBM email above eventually worked for me but I had trouble deleting the Trusteer folder. Windows would not let me delete one of the files RapportAegle64.sys because “It is in use by another program” although no other applications were running. I renamed it as a .txt file, rebooted and then was able to delete it. Edge now works ok.

    • Dear Peter H. Thank you for the advice. I’ve looked at the IBM email and the steps involved. I think this process is a bit too involved for people who are not tech-savvy and confident. So, I’ve resigned myself to not using the Edge browser and will just use Google Chrome instead for the foreseeable future. Regards.

    • I’m amazed that this is still an issue. Just spent 30 minutes with a client with Edge not opening to find Trusteer on there.

    • I give up totally…have used Rapport for years on IE. Now it seems to have gone haywire and cant print bank statements. Tried uninstalling and choosing Edge but icon does not show or Alt-r that Im protected. With Chrome icon is visible but greyed out. So after installing rebooting uninstalling etc for nearly 2 days to find problem…I give up. I bank with Nedbank

    • My system just completed a Windows Update where KB4058043 and KB4054517 were installed. After the completion of the install and reboot, I found that my Internet Explorer would not start. I disabled Trusteer, and IE started just fine. It looks like the problem with Trusteer my start showing up with IE after some current system updates. I went into the Trusteer Config and disabled the Early Browser Protection, and then IE loads just fine. Anyone else seeing issues with IE after system updates?

    • I have the same problem as Russel. My system is Windows 10 64bit ver. 1709 with all updates. After installing IBM Trusteer Rapport, the IE11 browser does not run on user accounts. It works only on the administrator’s account. Other browsers (Edge, Mozilla) work well. When I stop IBM TR, the IE11 browser works fine. I do not know how to solve this problem.

    • I can confirm that as of 17/12/2017, uninstalling Trusteer Rapport enables IE to start. It is not necessary to run IE as Administrator. With admin rights and TR installed, in my case IE fails to start. Its likely that TR is still not suppoprted on Edge, but IBM word their support for it as "an update for TR to support Edge will be installed in the background". I expect they are hopeful the problem and its solution will be largely unoticed by most users.

    • Just before Xmas my IE 11 would not launch using either of my 2 short cut buttons. I didn’t check if any updates had been recently actioned but after consulting with a friend who is very computer savvy it was discovered that TR was the cause of the problem. IE would launch as administrator but not in the normal mode. I noticed that Edge and Chrome were working normally. Uninstalling TR recovered the IE. I reinstalled TR but the problems returned so I uninstalled it via the Control Panel and have not reloaded it since. All my browsers are working fine and I have also noticed that my laptop boots up much quicker than before! I loaded TR a few years ago on the recommendation of my bank and until now it hadn’t caused any problems. Surprisingly, when I informed the bank of my experience they seemed to absolve themselves of any responsibility for TR and suggested I contact Trusteer support. I’m tempted to leave security matters to my Norton programme!

    • Windows updated today (11/4/18) and Microsoft Edge (ver 41.16299.371.0) crashed every time I started it!. I had the same experience with Internet Explorer some months ago and traced the fault to Trusteer Rapport. Switching off Rapport then allowed Internet Explorer to work, switching off Rapport now allows Microsoft Edge to work!.

      Rapport works fine in Internet Explorer now!.

      Anyway I decided to uninstall Rapport today (using IOBit uninstaller, rapport’s uninstaller didn’t work) then install my Banks version of Rapport!. Microsoft Edge works fine now (but Rapport doesn’t seem to be working inside it)!. Rapport works fine in Chrome and Firefox!.

      The makers of Rapport will probably fix this problem soon but uninstalling Rapport and shutting down your pc then installing your banks version of Rapport seems to be the answer for the moment!.

    • Edge had been failing to open. Yesterday (12 Apr 2018) I disabled Trusteer Rapport and Edge immediately began running. Until I found this forum I had to switch to IE. I since have removed Trusteer.

    • On or about April 15 I noticed Window 10 had installed updates and not long thereafter I noticed several shortcuts on my desktop were not working. IE and Edge were not working. Shortcuts to applications on my computer worked OK. After hours of trying to figure out what was amiss I asked Microsoft for help. The first Microsoft tech was not able to fix the problem and said he would hand off my trouble to a higher level tech and to expect a phone call the next day. A second tech called and he too was not able to locate the trouble. Third tech came on board and she was knowledgeable of the Edge and Trusteer Rapport software not working with each other. I’m up and running now, but our operating systems are getting so complicated that we novices are lost when things go wrong. Seems as though software programmers are competing to get their programs in front of computer users that they fail to verify their software with our O/S. I now recall my credit union had recommended I load IBM’s Trusteer Rapport a couple of years ago and it has worked until the latest Windows 10 update was pushed to my machine one night. If Microsoft techs can’t fix a problem why should we computer users be expected to pay someone else to fix a problem generated by the software company whom provided their software for our use. This all started for me when my credit union suggested I load Trusteer Rapport to add another security level when Iogged into my credit union account.

    • Took me a while to figure out that it’s Trusteer Rapport that was causing this but as soon as I stopped the service, Edge opened fine. am on Edge 16 btw

    • Spookily, I had another client with this same problem - I was only when I went through the list of programs installed that I went “ah ha” when I was Rapport. Uninstalling fixed it but then the latest version was re-installed and doesn’t cause the crash. No visual indication that it’s working either…

    • I agree with earlier commentators on here - it really is not acceptable that two large computing organisations cannot agree to work their apps amicably. IF MS does not want us to use Trusteer Raport, why doesn’t it come out with its own equivalent safe banking mode? It is astonishing that they both seem to resort to getting their users to become programmers or technical experts to make their software work! All those who claim they fixed the problem - good luck …until the next big MS update! this is the second time for me so I just wish we could remove Edge! BUT MS help relies on Edge opening - even if it is not the default browser and even while it wont work! One last point - I would not trust Internet Explorer or Edge, without added protection, for banking. Better to use Avast Safe Mode and their Banking mode (Sandboxed)

    • Thanks for the info. I was at this for weeks! Downloaded new Rapport from website and now all is well with EDGE. Here’s the link: https://www.trusteer.com/ProtectYourMoney .

    You need to sign in to your Microsoft account to add a comment.

    Sign in