Youtube and other Google site displays gibberish

Not reproducible Issue #13256077

Details

Author
Ohad R.
Created
Aug 14, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
15.15063
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

YouTube and other google sites displays gibberish.
This is not encoding issue - images are not displayed as well.
See attachments - youtube.bmp and google.bmp.

Other sites, such as yahoo, are loading just fine. See yahoo.bmp for example.

There was an issue, 1.5-2 years ago, issue that was introduced by AVG that caused Chrome to display Facebook.com just the way Edge is displaying Google sites now. I do not know if AVG had done it again, this time, affecting Edge, or if that “old” issue has nothing to do with this current issue, but it looks like a similar symptom, so I figured this could be a lead.

Done so far:
Run full virus scan, using AVG - no issues found.
Run full scan with Malwarebytes - no issues found.
Checked hosts file - nothing unusual.
Ensured the system is up to date (this includes Levono’s System Update, Windows Update, and AVG).
Reset trusted sites to default level.
Restored Advanced settings
Cleared SSL state
Verified on "HTTP settings", that HTTP 1.1, HTTP 1.1 through proxy, and HTTP 2 are all checked.
Rebooted the machine.

OS: Windows 10 Pro, 64-bit, version 1703, build 15063.540
Laptop: Lenovo T430, i5-3210M, 2.5GHz, 8GB Ram
Edge: 40.15063.0.0, EdgeHTML 15.15063
AVG: Antivirus Free, version 17.5.3022, virus definition version 170814-0

Kindly, h-e-l-p

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Steven K.”

  • Hi Ohad,

    Can you try with AVG disabled?

    Will you provide a network capture of the first request to www.youtube.com for me?  I have uploaded a screenshot if what I am looking for.  I would like to set the response header for the content-type, which I have highlighted in blue in the attached screenshot.

    Here is a outline of the steps:

    1. Go to youtube.com
    2. Hit the F12 key
    3. Go to the “Network” tab in the debugger window.
    4. Click the buttons on the title bar of the debugger to always refresh from the server, clear cache, clear cookies, and the clear entries on navigate.
    5. Fresh the webpage
    6. Search for the first GET request to www.youtube.com and then then look for the response header.

    Verify no personal data is shown on the screen.  Take a screenshot and attach it.

    Appreciate the help,

    Steve

  • Hi Steve,

    Thank you for your prompt response.
    Please find attached headers.bmp as requested.

  • BTW, I’ve attached the console log (though can’t see anything interesting). See console.bmp.

  • I am having the same problem on my laptop.

    OS: Windows 10 Home 64 bit, version 1703, Build 15063.540
    Laptop: ASUS ROG G751Jy-WH71(WX) Intel Core i7-4730HQ CPU @ 2.60GHz

    What’s funny is I am on my wife’s laptop with:

    OS: Windows 10 Home, Verson 1607, 14393.1593
    Laptop: Dell Intel Core i5-5250U CPU @ 1.60GHz

    It does not have this problem. I can go to Google and Facebook just fine on her’s. Please let me know what you find out.

  • I use AVAST as my virus protection, not AVG. Running a scan with AVAST also yielded nothing.

  • OK, so this might be a lead:

    OS: Version 1607, 14393.1593 => Yey!
    OS: 64 bit, version 1703, Build 15063.540 => Doh!

  • @Ohad, thank you for uploading the headers.bmp.  The encoding is set to UTF-8 and the console.bmp shows the same.  There is definitely an encoding issue though as seen in the console.bmp, and the original youtube.bmp.  The first line of the the HTML document for youtube’s webpage is “<!DOCTYPE html>” and is not being decoded correctly and there are null’s in the html page which should never be used in HTML.  I am rather sure this is not a youtube issue but something inbetween the browser and youtube. 

    https://msdn.microsoft.com/en-us/library/hh180764(v=vs.85).aspx

    Did you disable AVG and test again?  I am guessing these issues are related to a feature in AVG or other software/extension that is performing realtime browser protection or something along those lines.  Disable all extension and all of the features in AVG (re-anble after testing.)

    Also, do both systems (the working and non-working system) have the same web security software installed?  Even if they do, they could be at different version levels.

    @Jeffrey, run the same test with extensions disabled and any “realtime browser protection” software disabled.  I believe AVAST also has this feature.

    Another quick way to get to a clean state is to create a new user account in Windows.  Login as that user and run the same test.  This is assuming that the anti-virus software was not installed for all users.  If it was, you will still need to disable it.  However, this will remove any extensions as a potential cause.

  • @Steven,

    I have just uninstalled AVG, and rebooted the machine.
    And still - youtube.com gives giberrish.
    As for my previous comment, regarding the OS versions, I was just summarizing what @Jeffrey said. I have no idea what security software are installed on them. Sorry for not being clear about it.
    BTW, I have no extensions installed whatsoever.

  • @Jeffrey, did you manage to solve the issue?

  • @Steven,

    Here’s an update:
    https://www.google.com now results with "This site is not secure", and clicking the “Details” gives:

    The hostname in the website’s security certificate differs from the website you are trying to visit. 
    
    Error Code: DLG_FLAGS_SEC_CERT_CN_INVALID
    
    Go on to the webpage (Not recommended)
    

    Does this error code (DLG_FLAGS_SEC_CERT_CN_INVALID) gives you any lead?

    (BTW, youtube.com still same giberrish behavior)

  • Thank you for the update Ohad.  Can you show me what your computer returns for google’s IP address?  You can get this by opening a cmd.exe shell/prompt and typing:

    nslookup google.com

    Non-authoritative answer:
    Name:    google.com
    Addresses:  2607:f8b0:400a:800::200e
              216.58.193.78

    Can you give me information about your network?  Are you using a home network or a work network?  Are their any proxies for security application between your computer and the internet?  That warning is given when the page you are visiting is does not belong to the same domain as the certificate, E.g. to serve a valid SSL certificate the hostname of the server (e.g. serverXYX.google.com) needs to match the certs domain, *.google.com.  This error is a sign you are not going where you think you are going.  The nslookup mentioned above will help with that.

    Also, it might be good to check your ‘hosts’ file in: C:/Windows/System32/drivers/etc

    Also, you DNS entry could be modified on your computer.

    • Check that Settings ( Win + i )
    • “Network & Internet”
    • “Change adapter options”
    • Right click on the adapter/connection you are using and select 'properties’.
    • Click on either "internet Protocol Version 4(TCP/IPv4)" or the equivalent IPv6 entry and click the Properties button.
    • Check if the radio button is set for "Obtain DNS server address automatically".

    You could also try using a manually entered DNS server as well, such as OpenDNS: https://use.opendns.com/

    208.67.220.220
    208.67.222.222

    Some routers will override whatever you put here and some will not, but worth a try.

  • @Steven,

    Here’s the output:

    
    C:\Users\Meytal.Raz-Laptop>nslookup google.com
    Server:  pcache.orange.net.il
    Address:  82.102.139.10
    
    Non-authoritative answer:
    Name:    google.com
    Addresses:  2a00:1450:400e:803::200e
              172.217.17.142
    

    This is a home network.
    No proxies (thatI’m aware of…)
    I checked the host file at the very first step (check the third item I mentioned in “Done so far:” of the initial report of the issue).
    I had my TCP/IPv4 set on "Obtain DNS server address automatically". I selected "Use the following DNS server addresses", and specified the Preferred DNS server as 208.67.220.200, and the Alternate DNS server as 208.67.222.222.
    I then tried going to www.google.com from InPrivate (to make sure no cookies no cache no nothing), and indeed, there was no security message. However, the site did displayed giberrish…
    And so, the problem remains…

    BTW, I’d love for some explanation about this DNS thingy… You see, I am connected to this very same network, the very same way - WiFi (no LANs), with my mac, and I have no issues (true, from the mac I am using Safari, but still - if it is a DNS thingy, I would expect all browsers to fail the same).

  • @Steven,

    Woooowww…
    Here’s an interesting update:

    As I said earlier - I switched from "Obtain DNS server address automatically" to "Use the following DNS server addresses", and used your suggested openDNS settings.
    This attempt did solve the security error message, but it did not solve the original issue - giberrish on youtube and other google sites.

    So I just decided to switch back, from "Use the following DNS server addresses" to "Obtain DNS server address automatically".
    And now - issue is solved (WHAT???)

    So I guess you can close this issue, but please, and I am sure you are very busy, tons of issues on your hands, but if you could be kind enough to spare 10 more minutes on this thread and explain what is going on here, because nothing makes sense to me whatsoever.

  • (and I checked the versions of AVG and Windows. Windows was not updated, well 2 days ago, with some Flash security thing that doesn’t seem to have anything to do with this issue, and AVG was not updated; well, the virus definition was update, but not the "program", and I expect the behavior I’ve encountered with the giberrish not to be related to the virus definitions, but to the program itself). So kindly help me figure out what went wrong here…

  • @Jeffrey, just to see is this helps you as well - can you change your DNS settings to openDNS as @Steven suggested, apply/OK the whole way though, and then try to switch back DNS to automatic DNS obtaining, apply/OK everything and retry browsing to youtube?

  • Thank you for the feedback and glad it is working.

    I am not exactly certain which solved this issue for you because I am not sure which happened first the AVG application update or the DNS cache expiring and finally using your new DNS settings.  Perhaps, changing from auto to manual forced the cache to refresh.

    Also, sometimes if IPv4 and IPv6 are enabled at the same time, the DNS resolution, i.e. converting human readable website names to IP addresses, e.g. 172.217.6.174 for google.com., will not work properly.  That is more of a combination of the user’s network and the way the mismatch is handled in Edge.

    Here is some reading on DNS Caching.

    https://www.lifewire.com/what-is-a-dns-cache-817514

    Also, you could try to flip between manual and automatic DNS again and see if it breaks.  If it does than you need to sort out a local network configuration.  However, my guess is that it was AVG’s application update that corrected the issue.  I.e. this explains the encoding problem.  The encoding problem would only occur if the site that DNS gave you was not the correct site and that “fake” or wrong or cached version had an encoding issue.  Less likely.

    Thanks again for responding so quickly.  I am going to close this a what we call “no repro” because it was a configuration or something external to Edge.

    Steve

  • Microsoft Edge Team

    Changed Status to “Not reproducible”

  • Steven,
    I tried using openDNS, and it continues to load just fine.
    So I guess this whole thing can be put down to AVG…
    Thanks for your help and explanations.

    Cheers,
    Ohad

  • Anytime Ohad.  I was thinking more about this bug report and it does make sense that it would be a tool like AVG inserted in between that can see and modify the content of a webpage.

    Thanks again for the support,

    The MS Edge Team

You need to sign in to your Microsoft account to add a comment.

Sign in