Checkboxes and radiobutton are not checked in contenteditable properly.

Fixed Issue #13497247

Details

Author
Mateusz S.
Created
Aug 29, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
  • Internet Explorer
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

Steps to reproduce:

  1. open link: https://codepen.io/msamsel/pen/wqQGLq
  2. Check behaviour of added elements in contenteditable.

Expected.
Input element added in contenteditable will gain proper ‘checked’ value when setAttribute method is used.

Actutal:
Input elements doesn’t get proper checked value.

Issue find out on Virtual env IE11 and Edge downloaded from modern.ie.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “James M.”

    • Hello,

      Thank you for providing this information about the issue. After thorough testing, we are unable to reproduce this problem in Edge. Please test this behavior in our latest creator’s update 15063 or the insider build 16275.

      Best Wishes,
      The MS Edge Team

    • Yes you have right. I’ve checked it on Edge 14 and there problem exists but in 15 and 16 I cannot reproduce it.
      But still situation exists on Internet Explorer. Is there a chance to fix it on IE11?

    • Microsoft Edge Team

      Changed Status to “Fixed”

    • Hello,

      Thank you for providing your feedback on IE11. We are not accepting feedback on Internet Explorer through this portal any longer (unless security related). We welcome any feedback you have on Microsoft Edge through this website.

      Best Wishes,
      The MS Edge Team

    You need to sign in to your Microsoft account to add a comment.

    Sign in