IE 11 Permission Denied Javascript

Won’t fix Issue #13625801

Details

Author
ALAN D.
Created
Sep 7, 2017
Privacy
This issue is public.
Found in
  • Internet Explorer
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Please see the attached HTML file. I am using ie version 11.0.96

When I load the HTML the debugger console shows script70 Permission Denied for a simple javascript console.log.

Any ideas appreciated.

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “James M.”

    Changed Status to “Won’t fix”

  • Hello,

    Thank you for providing your feedback on IE11. We are not accepting feedback on Internet Explorer through this portal any longer (unless security related). We are pleased to report this is fixed in Microsoft Edge.

    Best Wishes,
    The MS Edge Team

  • Changed Status from “Won’t fix”

  • Hello, thank you for the response, however could you please provide me an overview of what this issue with IE 11 is? Why this error occurs and if there are any documented work arounds? thank you

  • Microsoft Edge Team

    Changed Assigned To to “James M.”

    Changed Status to “Won’t fix”

  • Hello,

    Thank you for the update. This works fine in IE11, but the webpage might be restricted from running scripts or Active X controls. If you see a popup at the bottom of IE11, then please allow the blocked content. To always allow local files to run scripts, simply go to the Advanced Settings and under Security check the box for Allow active content to run in files on My Computer
    .

    I suspect you will not have this problem when the html file is loaded from a website.

    Best Wishes,
    The MS Edge Team

  • Changed Status from “Won’t fix”

  • Hello

    Please see the attached screenshot.png.

    I receive the error both when trying to render the page locally from the file system and when serving the page through a web or http server.

    When rendering the page locally yes a notification for Active X appears but not when serving via a web server. The error occurs in both scenarios.

    Thanks Alan

  • As you can see from screenshot, there is no Axtive X warning and the page is servered via web server. Thank you

  • Microsoft Edge Team

    Changed Assigned To to “James M.”

  • Hello,

    Thank you for providing detailed feedback on IE11. I still suspect your repro will work when served from a domain name but not from localhost. Regardless, we are not accepting feedback on Internet Explorer through this portal any longer (unless security related). We welcome any feedback you have on Microsoft Edge through this website.

    Best Wishes,
    The MS Edge Team

  • Microsoft Edge Team

    Changed Status to “Won’t fix”

You need to sign in to your Microsoft account to add a comment.

Sign in