Submit doesn't work with html file containing form and iframe

Fixed Issue #13713278

Details

Author
Rishabh J.
Created
Sep 13, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
40.15063
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

We have this form

<form method="get" target="post-iframe" action="http://localhost:8108/Channels/HTTP/AllOps">
<input name="AccountId" value="Bob">
<input name="Balance" value="20000">
<input name="AvgMonthlyBalance" value="11000">
    <button type="submit">Submit</button>
</form>
<iframe name="post-iframe" id="post-iframe"></iframe>

It is generally shipped as a html file with our product. User starts our server and can use this html file to submit test data. The file is opened from directory in web browser. It works directly on all modern browsers including IE 11. In Microsoft Edge 40.15063.0.0 it doesn’t work. There is no activity on submit in F12 - Network tab. If we keep this html file in a web directory and open from http://localhost:port/dir_name/file_name.html, it works.

Attachments

1 attachment

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “James M.”

    Changed Status to “Fixed”

  • Hello,

    Thank you for providing this information about the issue. We are pleased to report this feature is fixed in Edge 16281 and is available in our latest Insider Preview build in the Fast ring.

    Best Wishes,
    The MS Edge Team

  • Hi,
    When will the fix available for public users? I am currently on Microsoft Edge 40.15063.674.0 Microsoft EdgeHTML 15.15063

You need to sign in to your Microsoft account to add a comment.

Sign in