MS Edge has become difficult to work with, after the September 2017 security update

Issue #13749653 • Assigned to wptcomptri@microsoft.com

Details

Author
Rod F.
Created
Sep 14, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
15.15063
Reports
Reported by 4 people

Sign in to watch or report this issue.

Steps to reproduce

Last night (9/13/2017) my PC installed the September 2017 security updates. Now today I am struggling to use MS Edge. Most pages, regardless of what website, don’t come up. Often, if they do (such as this page I’m writing this note on now) I’ll get a message telling me that the page is "being recovered". Performance is slow.

Steps to reproduce: Just try using it.

Attachments

1 attachment

Comments and activity

  • Ditto here. Up vote on this.

  • Microsoft Edge Team

    Changed Assigned To to “Steven K.”

  • Hi,

    Have you tried clearing your browser cache?  Do any other browsers have the same issue?

    Also, is the App Store working properly?

    Appreciate the help,

    Steve

  • same here. have google search page as home page. type about 3-4 words of a search then locks up and says not responding

  • I have a different issue with the latest update KB4038788 installed on 9/12.

    I am missing layout parts at the top of the screen on Edge. Favorites star is missing, “X” for closing tabs, etc. Here is a screenshot. I have also removed the app package and reinstalled it with no change.

  • After posting my issue, about an hour later, after closing edge then re-opening, all of the icons have now appeared!! Am I crazy or what?

  • Later today, a second “Update and Restart” occurred with my machine, and Edge has behaved ok since.

  • We’ve noticed two specific issues since the security update:

    1. In fresh tabs, the window "dragover" event is firing with the wrong event target. Try this:
    
    
     
    
     
    
    
    
    
    

    In a fresh tab, that’s reporting ..., but if you refresh the tab or flip between tabs, it will correctly report ``.

    1. Invalid(?) URLs cause no action instead of an error. This includes trying to go to localhost instead of http://localhost; Edge doesn’t automatically prepend the protocol, and the browser appears to do nothing. Sometimes it pops up the “You need to download an application to open this file” window and that can lead to the browser hanging.
  • … The comment thing stripped the code. Here it is as a gist: https://gist.github.com/zbjornson/016a622c502f108bc87e8cea986fc30b

  • Microsoft Edge Team

    Changed Assigned To to “wptcomptri@microsoft.com”

  • I would like to know why MS created a new browser over a year ago and still has issues?

    Why is Chrome so stable and Edge is not?

    I am an MCSE and cannot understand why MS is falling behind?

    Please respond!

  • This is happening on every single computer on our network. Literally hundreds of them. It seems to clear itself up after a couple of days, but that September 2017 cumulative update totally kills Edge right after it’s installed.

  • We see this issue in our domain as well, happens with build 1703. We also have a software restrictions per machine configured, but we are excluding DLL libraries and we still see the issue.

  • https://support.microsoft.com/en-us/help/4040724/windows-10-update-kb4040724

    “Addressed issue in Microsoft Edge where on first launch after installing KB4038788, or periodically thereafter, users may observe performance issues or unresponsiveness until the next launch of the browser.”

You need to sign in to your Microsoft account to add a comment.

Sign in