Once joined to Domain, Microsoft Edge can only print from sites in the Trusted Zone

Fixed Issue #14224105

Details

Author
Matt M.
Created
Oct 14, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
15.15063
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Fresh install of Windows 10 Enterprise 1703 with all windows updates.  Once joined to our Windows Domain, Microsoft Edge loses the ability to print from any website not in the ‘Trusted Zone’ (which includes Intranet sites and network shares).  Our Domain is a 2008 R2 w/ latest Windows 10 templates applied.  The print jobs are sent to both network printers and the local Print to Microsoft PDF.

When trying to print from any website such as Amazon or MSN.com, the mouse cursor transitions to a cursor with a small spinning wheel, the print queue instantly changes the blank status at the bottom of the queue window from nothing to ‘0 document(s) in queue’ and nothing actually prints.  If Microsoft Print to PDF is selected, it will print a zero byte PDF file.  Running Wireshark during this process shows ZERO packets being set to the printer, so the print job is dying internally within Windows 10 and not generating any network packets.

If I add amazon.com or msn.com to the Trusted Zone in group policy, Edge can suddenly send print jobs without issue to the same printer(s).  It will also properly print to PDF.

Setting a default printer has no effect.  Running the powershell script to reset Microsoft Edge has no effect.  Running sfc /scannow has no effect.  Changing printer drivers has no effect.

This happens to each and every Windows 10 Enterprise install that we join to our network (fresh installs - I’ve tried it about 10 times now with the same results).  I have even tried moving the user account and workstation account to Organizational Units in Active Directory that have no group policy and the problem remains.  I can only think it has something to do with the enhanced protected mode gained when joining a workstation to a Domain.   If the fresh installs are not joined to the domain they can print normally.

Thank you,

Matt

Attachments

0 attachments

    Comments and activity

    • Just upgraded to 1709 Creators Update 2 and the problem remains.

    • Microsoft Edge Team

      Changed Assigned To to “Scott L.”

    • We too are experiencing a very similar issue trying to print any pages from the Edge Browser. If I move the site into the “Trusted Site” Zone the print dialog box appears and I am able to print but anything within the Internet Zone does not print. In our environment we are able to print from our Intranet Zone. We are also running Windows 10 Enterprise (1703) and Microsoft Edge 40.15063.674.0 in an similar Active Directory Domain environment.

      One other item worth noting is that we do have EnableLUA set to DWORD value of “0” and if I change this to a DWORD value of “1” Printing also works. When I enable the Developer tools and try and print I receive the following error "SCRIPT65535: Unexpected call to method or property access.
      preview.js (358,1)"

      Any help would be greatly appreciated as it is having a significant impact to our machines.
      Thanks,
      Guy

    • I finally narrowed it down on my network a couple of days ago. We run iVanti ( Heat / Lumension) EMMS software for security. A component of their package is a “device control” plugin. I have no policies set for the plugin, but just having it installed on the workstation breaks Edge printing. Once I removed the plugin, all workstations regained the ability to print.

    • Microsoft Edge Team

      Changed Assigned To to “Sermet I.”

      Changed Status to “Fixed”

    • Hello,

      Thank you for sharing your problem and solution. Please reopen this case if you have new information about this specific issue for us to investigate.

      Best Wishes,
      The MS Edge Team

    • This is still an issue in our environment. The information I provided above is still relevant to the issue we are experiencing.

      Thanks,
      Guy

    • Microsoft Edge Team

      Changed Assigned To to “Sermet I.”

      Changed Status from “Fixed”

      Changed Status to “Fixed”

    • Hello Guy,

      Thank you for providing this update. The printing problem is due to User Account Control being turned off, and it should be addressed in the next major update. In the meantime, please avoid turning off UAC. (Turning UAC off creates additional security risks, anyway.)

      Best Wishes,

      The MS Edge Team

    • Thanks very much for the information James. I do understand there are additional security implications with turning UAC off but we do have valid reasons for not having this enabled and do have other security measures in place to help protect against any malicious intent. You mention that this should be addressed in the next major update, would this be the 1709 release or a subsequent update, and if so what does the timeline look like for that release?

      Another question would be, is there currently any “workaround” that would allow us to have Edge Printing capabilities even with UAC off? The reason I ask is that I do have one machine that has the same release of Windows and EDGE and Edge Printing does work on any site. I have been trying to see what might be different on this machine but have had no luck so far. Wondering if there is something that we could do as a work around (that is not turning UAC on) until the next upgrade becomes available?

      Thanks,
      Guy

    • Microsoft Edge Team

      Changed Assigned To to “James M.”

    • Hello,

      The next major release is in the spring of 2018, and we hope to have the fixed pushed out by then.

      For some users, the current workaround is moving sites to the Trusted Sites zone in Internet Explorer.
      For other users, the current workaround is turning UAC on.

      Best Wishes,
      The MS Edge Team

    You need to sign in to your Microsoft account to add a comment.

    Sign in