Many WebM videos still don't work in Edge 16 / Fall Creators Update 16299.19

Needs root cause Issue #14287047 • Assigned to Erik A.

Details

Author
Vladimir N.
Created
Oct 18, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
16.16299
Needs root cause
Sign in to suggest a root cause.
Reports
Reported by 5 people

Sign in to watch or report this issue.

Steps to reproduce

To reproduce the issue visit http://www.webmfiles.org/demo-files/ . The video at the bottom will say "This type of video file is not supported".

So, some progress has been made in Edge 16, but still around 50% of the WebM videos I find on the web don’t work.

Furthermore http://html5test.com still reports that WebM is not supported by Edge 16.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “James M.”

    • Also, still a problem on 64-bit Edge. I tested both a VP8 and a VP9 and both fail. (This is my SECOND complaint on this issue…the first was back in April.)
      I’m testing using Fall Creators Update. The version # is
      Microsoft Edge 41.16299.15.0
      Microsoft EdgeHTML 16.16299

      I’m really p*ssed that this still doesn’t work. I went out of my way after posting here back in April, to get the info on wikipedia changed from green (supported) to pale yellow (only via MSE) in the chart here:
      https://en.wikipedia.org/wiki/HTML5_video
      And, I’m gonna continue to be on your case, until you implement this
      correctly. To re-create the issue, simply take any standard MP4 video
      (e.g. H.264/MP3) and convert it using the FFMEG conversion program
      and watch them both fail.

      Do you at least agree that these are valid test images?

    • I’m guessing the problem is that Vorbis audio is still not supported:

      https://developer.microsoft.com/en-us/microsoft-edge/platform/status/vorbisaudiocodec/?q=vorbis

      If that’s the problem, I would expect to at least play the video, without audio, but it doesn’t.

    • Microsoft Edge Team

      Changed Assigned To to “Venkat K.”

    • We are experiencing the same issue with webm. Please provide an update as to when this will be fixed.

    • Microsoft Edge Team

      Changed Assigned To from “Venkat K.” to “Erik A.”

      Changed Status to “Needs root cause”

    • Hmm…I’ve resolved my major roadblock to getting my WEBM-based markup working in Microsoft Edge 41.16299.15.0. The markup

      fails. But, simply removing the type-attribute specification allows the content to be correctly rendered. Or, eliminating use of a source tag altogether, and using just the video tag (where no type-attribute is allowed) resolves the issue.

      One other issue is that needs work is support VTT-support, so that

      is honored.

    • is erroneously flagged as invalid source.

    • Do you allow a source-tag with type of video-slash-mp4 ? (yes)

      how about one with type of video-slash-webm ? (no)

      therein lies a problem.

    • Installing the Web Media Extensions from the Microsoft Store fixed this for me, I cannot reproduce the issue I reported after installing it.

      https://www.microsoft.com/store/productId/9N5TDP8VCMHS

      The html5test site also now reports WebM and the associated codecs as supported, with one exception, “WebM with Opus support” for audio. Which is a bit strange since the same codec is supported for streaming, not sure if that’s a bug on their test or not.

    • Hmm…as this saga plays out, things are appearing to me to be MORE than just “a bit strange” ! ;^)

      I’m still in mumble-mode. My understanding has been that the whole goal of this latest Edge release was so ppl would NOT HAVE TO install WME. (I finally got Webm/Opus to stream WITHOUT installing WME, once I stumbled upon the bug-workaround to NOT explicitly declare a type of "video/webm’ within a SOURCE tag, as the material at W3Schools recommends.)

      This most recent post of mine is just to clarify my situation/solution, in case my three previous posts weren’t perfectly clear. [ This has taken me 4 posts because I’m 73-years-old and because this crazy issue-reporting system ALSO seems to have been implemented in a sub-standard fashion…i.e. I can’t find any “edit your most recent post” feature and because its “Preview” feature doesn’t seem to behave in a WYSIWYG fashion. ]

      I feel compelled to further report that I’m (once again) moving away from Windows-10 as my development-platform-of-choice. (Last time it lasted about 5 years…it was from Vista to Linux). This time, I’m moving from Win-10 to Chrome-OS. Specifically, I’m moving to what I refer to now as the new ‘hybrid’ edition of Chrome-OS, wherein you run Chrome-OS/Android on a laptop/tablet. So, just two days ago, I celebrated 'cyber-Monday’, by deciding to gift-away my one-year-old Acer chromebook, and order myself Google’s new Pixelbook. In the next week or two, I should be able to conclude whether this decision was a sound one. Stay tuned.

    You need to sign in to your Microsoft account to add a comment.

    Sign in