Setting Edge as default web browser in Windows

Fixed Issue #14297935

Details

Author
Murtaza I.
Created
Oct 19, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Not sure if this is the correct platform for this issue but I am posting it here since other channels have proven to be in-effective.

I am unable to set Microsoft Edge as the default browser on my machine as Edge is not available in the web browser list (screenshot attached). This has been the case at least since the Anniversary Update and I am currently on Creators Update.

It appears that I’m not alone facing this issue either (link below).

https://answers.microsoft.com/en-us/windows/forum/windows_10-networking/ms-edge-not-listed-in-default-browsers/dd448253-c9c5-40ad-8f62-29c1b690219a

Bonus Issue: In the attached screenshot, the web browser list shows Chrome along with Firefox although I have uninstalled Chrome from my system!

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Steven K.”

  • Hi Murtaza,

    I see that even the Chrome application option is not as it should be, I.e. the icon for the application is missing in your screenshot.

    Have you tried clicking the “Rest to Microsoft’s recommended defaults” button?  This is also shown in the screenshot you sent me.

    Let me know,

    Steve

  • I tried resetting the defaults, and while it did set Edge as the default browser, it doesn’t show up in the browser list. Also, Chrome is still in the list, so the Web browser list is not showing properly. I’ve added another screenshot after clicking the ‘Reset’ button.

  • I recommend doing two things:

    1. Uninstall Chrome.  You can re-install after the next step if you would like to.
    1. “Reset” Edge back to the defaults.  Following the procedures in this link to do that.

    https://answers.microsoft.com/en-us/windows/forum/apps_windows_10-msedge/how-to-recover-microsoft-edge-if-it-fails-to/7cd3b30c-7d38-466c-8ee2-1b96fdf06580?auth=1

    Let me know how it goes,

    Steve

  • Hi,

    Just checking for any updates on this bug report.

    Steve

  • Hi, I recently updated my machine to FCU and linked my user to my microsoft account. Either one or both of these changes have fixed the issue.

  • Steve, how am i supposed to uninstall Chrome when its already uninstalled? I think you missed my initial bug description where I mention that Chrome is showing in the list although I have uninstalled it from my system.

    So this is probably not a problem with just Chrome or Edge, rather with Windows.

  • Microsoft Edge Team

    Changed Status to “Fixed”

  • Hi Murtaza,

    I think I was confused by the screenshot, even though you explained it as being odd, I.e. the bonus issue!  :-/  Sorry about that.  Also, I was thinking of trying to do something with PowerShell.

    Either way, I am glad it has been corrected.  I appreciate you giving that update.

    We will keep an eye on other users experiencing the same thing.

    Appreciate the help,

    Steve

You need to sign in to your Microsoft account to add a comment.

Sign in