UnknownError on creating IndexedDB

Needs root cause Issue #14372843 • Assigned to Ali A.

Details

Author
st n.
Created
Oct 25, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
  • Internet Explorer
Found in build #
15.15063
Needs root cause
Sign in to suggest a root cause.
Reports
Reported by 10 people

Sign in to watch or report this issue.

Steps to reproduce

When I try to create an IndexedDb using indexedDB.open(“mydb”); it throws an UnknownError in IE and Edge, all other Browsers work as expected.

You can reproduce the issue running the following codepen: https://codepen.io/cemerick/pen/Itymi

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “James M.”

      Changed Assigned To to “Venkat K.”

      Changed Assigned To from “Venkat K.” to “Ali A.”

      Changed Status to “Needs root cause”

    • The issue still exists in IE 11.15.16299.0 and Edge 41.16299.15.0 / EdgeHTML 16.16299

    • Same here… Is really bugging me, because nearly all of my clients are working with IE and our application depends on the IndexedDB.

    • I’ve just figured out that creating an IndexedDb works in IE 11.0.9600.17420, so this might be a bug in one of the updates of IE 11 that followed that version. This is a huge problem for us and we would appreciate if you could fix it soon.

    • I have the same issue with my application. Works perfect chrome and firefox but not with IE11 and Edge

    • Same here. It’s really annoying. Pls fix it.

    • Glad I’m not the only one struggling with this problem. Please try to fix it ASAP.
      Client complaints rising…

    • I’m facing the same problem. It’s strange that IndexedDB was working in earlier versions of IE 11. Can’t you put the old implementation back? My application relies heavily on this feature and therefore currently does not work in IE and Edge. Please increase the priority of this issue. Thank you.

    You need to sign in to your Microsoft account to add a comment.

    Sign in