PlayReady DRM Content Previously Supported on Edge 15 not working in Edge 16

Fixed, not yet flighted Issue #14593018


Ian B.
Nov 9, 2017
This issue is public.
Found in
  • Microsoft Edge
Found in build #
Reported by 12 people

Sign in to watch or report this issue.

Steps to reproduce

PlayReady protected content that played successfully in Edge 15 no longer works in Edge 16. 

Reduced repro:

-Potentially related to open issue, reference ID 14554354
-Receiving error 3016 from Shaka:
The video element reported an error.[0] is a MediaError code from the video element. 
On Edge & IE,[1] is a Microsoft extended error code in hex.[1] returns 80004003[0] returns error code 4, MEDIA_ERR_SRC_NOT_SUPPORTED

Reproduction Steps
Test Page: <redacted>

  1. Open this page in Edge 16.
  2. Wait a few seconds and the player will automatically display a {{Error loading media: File could not be played error}}.
  3. Open the same page in Edge 15 or IE 11.
  4. Witness the stream play properly.


  • Hardware/Device
    ** Lenovo Laptop / Browserstack
  • Operating System
    ** Windows 10 Fall Creators Update
  • Browser
    ** Edge 16
  • JW Player Version / URL
    ** 8.0.0 / <redacted> 


0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Steps to Reproduce

      Changed Assigned To to “James M.”

      Changed Assigned To to “Venkat K.”

      Changed Assigned To to “Stephen E.”

    • Hello Ian,

      out of curiosity, what was the packager you are seeing the issue with? The same error started occuring for me with Edge 16 and IE on Fall Creators Update and PlayReady MPEG-DASH content generated by Wowza. However, for example MPEG-DASH PlayReady generated by mp4box is still fine.

      The issue is relevant to PlayReady with MPEG-DASH only as Smooth Streaming variant of the same PlayReady content plays fine from Wowza AND the same but unencrypted content works with MPEG-DASH as well. I cannot access mentioned issue #14554354. But from what I can see, it does not seem to be related directly to issue #12658991 as mentioned boxes from Wowza have “expected” order and a comment about removing clear section from the content in that ticket does not apply as well as Wowza is encrypting from the first frame.

      To reproduce with HTML5 and Silverlight player available here and default license server,sl:150) :

      HTML5 & MPEG-DASH fails

      HTML5 & Smooth Streaming works

      Decoding and decrypting in Silverlight on IE works with both protocols.


    • Microsoft Edge Team

      Changed Assigned To from “Stephen E.” to “Ramy W.”

      Changed Assigned To from “Ramy W.” to “Matthew H.”

    • I also have this issue with Edge 16 and IE on Fall Creators Update with YouTube Purchased Movies. It will give me the error “An error occurred. Please try again later.” I tried it on a different PC with Edge 15 and it works fine. Is there a workaround for Edge 16? The movies will play on Firefox just fine.

    • Microsoft Edge Team

      Changed Steps to Reproduce

      Changed Title from “PlayReady DRM Content Previously Supported on Edge 15 not working in Edge 16” to “PlayReady DRM Content with Key Rotation Previously Supported on Edge 15 not working in Edge 16”

      Changed Assigned To from “Matthew H.” to “David S.”

    • Since Microsoft Edge Team added the repro link back to the OP’s message, I now see that they are using Wowza as well.

      I believe that the issue is the same for both of us and that it stems from the sudden incompatibility between EdgeHTML 16 and how the content is packaged with PlayReady from Wowza. Therefore I feel that the changed title referring to key rotation might be misleading as there is no key rotation involved in our case. Our encryption key is static, because we are serving encrypted VoD content and not live.

      Can’t compare it with Youtube as another commenter added, but like I said previously, content encrypted with PlayReady in mp4box still works fine in EdgeHTML 16, so it probably is something on the box-parsing level.


    • The same issue is observed on our side with Playready protected streams from Wowza platform. In our case there is also no key rotation present which makes the original title of this issue more fitting.

      Would you have any update on what’s causing the issue; when this is expected to be resolved and if there may be some possible workarounds for this issue.

    • Microsoft Edge Team

      Changed Status to “Confirmed”

      Changed Title from “PlayReady DRM Content with Key Rotation Previously Supported on Edge 15 not working in Edge 16” to “PlayReady DRM Content Previously Supported on Edge 15 not working in Edge 16”

    • We are also experiencing problems using Wowza with playready on Edge. Any ETA on the fix?

    • Microsoft Edge Team

      Changed Status from “Confirmed”

    • Can we expect a fix from the Microsoft Edge team on this issue?

    • Hello,

      Thank you for providing this information about the issue. We are presently tracking this issue as a duplicate of an existing internal bug report. We look forward to additional feedback you may have on how we can improve Microsoft Edge.

      Best Wishes,
      The MS Edge Team

    • Hi James

      Is there any visibility when this issue can be resolved?

      A subset of our customers is using Wowza with Playready DRM to deliver premium video. services At this moment the only thing we can do is people to advise to use another browser, which is not a preferred solution.

      If we can communicate on a target version of Microsoft Edge when this will be resolved we can already anticipate in terms of communication.

      Thanks in advance for your feedback


    • Hi James M,

      Joining with posters above me, it is important that this issue is resolved in as timely a manner as possible since it is impacting upon our customers. The software in use implements Microsoft edge and, as such, using another browser is not an option. While this issue remains unsolved, the application is useless to anybody who is on this version (and there is also no way to roll back after 10 days given Microsoft’s new update policies).

      Some more informative feedback on the issue and any kind of confirmation that the issue is being handled presently would be much appreciated. Is there any news on when a fix might be expected?


    • James, we also provide a premium, subscription based streaming service. We have added a poster advising our customers with Edge to switch to chrome or firefox because of this issue.

    • Microsoft Edge Team

      Changed Assigned To to “David S.”

      Changed Status

      Changed Status to “Confirmed”

      Changed Status from “Confirmed” to “In code review”

      Changed Status from “In code review” to “Fixed”

    • Glad to se this issue marked as fixed. When is this fix available in a publicly available version of MS Edge?

    • Microsoft Edge Team

      Changed Status from “Fixed” to “Fixed, not yet flighted”

    • We are running a service used throughout the UK which is based on a Windows 10 app with DRMed downloaded content. So there are no workaround we can apply - like using another browser, as is not browser based. We are increasingly finding that our users can’t source machines that have not updated to 1709. This is mission critical. So please can we have a respond on when this fix will be released. Thanks Patrick

    • Hello - The fix has been shipped to Windows Insiders Program users, the most recently build is 17120.  

      We are currently working to backport the fix to Windows 10 Fall Creators Update users and it should be available in the next couple of months.  Thanks! 

    You need to sign in to your Microsoft account to add a comment.

    Sign in