Camera activity indicator remains active after stopping tracks, when acquiring an audio video stream.

External Issue #14751307

Details

Created
Nov 20, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
16.16299
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

Hello,

The camera activity indicator remains active after stopping all tracks from a previously acquired stream. This only seems to happen when acquiring an audio and video stream.

In pseudo-code (full test case attached):

stream1 = getUserMedia({ audio: true, video: true });
stream1.eachTrack(t => t.stop()); // camera remains active

stream2 = getUserMedia({ video: true });
stream2.eachTrack(t => t.stop()); // camera does not remain active

Microsoft Edge 41.16299.15.0
Microsoft EdgeHTML 16.16299

I’ve also tested this in other browsers and the camera was released successfully.

  • Google Chrome Version 62.0.3202.94
  • Mozilla Firefox Quantum 57.0
  • Apple Safari Version 11.0.1 (12604.3.5.1.1)

Thanks for your time. Please let me know if you need more information or something is unclear.

Have a great week!

Copied from Description when changed from Task to Bug

Copied from Repro Steps when changed from Bug to Task

Hello,

The camera activity indicator remains active after stopping all tracks from a previously acquired stream. This only seems to happen when acquiring an audio and video stream.

In pseudo-code (full test case attached):

stream1 = getUserMedia({ audio: true, video: true });
stream1.eachTrack(t => t.stop()); // camera remains active

stream2 = getUserMedia({ video: true });
stream2.eachTrack(t => t.stop()); // camera does not remain active

Microsoft Edge 41.16299.15.0
Microsoft EdgeHTML 16.16299

I’ve also tested this in other browsers and the camera was released successfully.

  • Google Chrome Version 62.0.3202.94
  • Mozilla Firefox Quantum 57.0
  • Apple Safari Version 11.0.1 (12604.3.5.1.1)

Thanks for your time. Please let me know if you need more information or something is unclear.

Have a great week!

Attachments

1 attachment

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “James M.”

    Changed Assigned To to “Venkat K.”

    Changed Assigned To from “Venkat K.” to “Nishant N.”

    Changed Assigned To from “Nishant N.” to “Frank L.”

    Changed Assigned To from “Frank L.” to “Gurpreet V.”

    Changed Assigned To from “Gurpreet V.” to “Angelo L.”

    Changed Steps to Reproduce

    Changed Assigned To from “Angelo L.” to “Gurpreet V.”

    Changed Status to “External”

  • Hello,

     

    Thank you for providing this information about the issue. We
    have confirmed the problem, and are considering a solution for a future build
    of Edge.
    We are resolving this issue as a duplicate of an existing feature
    request. We look forward to additional feedback you may have on how we can
    improve Microsoft Edge.

     

    Sincerely,

    The MS Edge Team

  • This issue has been resolved External. This means this issue may require a new feature to be implemented or other work that is more significant than a typical bug. You may be able to find more information on this issue by searching for related features on status.microsoftedge.com and uservoice.microsoftedge.com.

You need to sign in to your Microsoft account to add a comment.

Sign in