Login dialog does not take any input on yellowdig.com ("pointer-events: none" does not affect iframes)

Fixed Issue #14961910

Details

Author
Kozyatin D.
Created
Dec 5, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
16.16299
Fixed in build #
17.17619
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Diagnostic data is available and has been analyzed automatically with the most relevant hints listed to detect the underlaying issue. Please find the insights listed below.

Hello! I’m trying to apply pointer-events: none; to iframe, but it does not work, I’m still able to click anything inside the iframe. Also it does not work if I apply pointer-event to iframe’s parent container.
This is a bug in Edge v16 (Edge/16.16299), everything works fine in Edge v15 and below.

Best regards,
Dmitriy

Please see other feedbacks in userfeedback VSO for feedbacks that are tracked by this work item.

h3 {
color:#2f5496;
font-family:Segoe UI;
font-size:small;
padding-left:3%;
}

table {
font-size:small;
width:95%;
}

th, td {
font-size:small;
padding:5px;
}

td {
border:0.5px solid white;
}

th {
background-color:#8B8989;
color:white;
}

.feedback-leftcell {
width:20%;
color:#004d8b;
}

.feedback-row:hover {
background-color:#C4C4C4;
}

#feedback-banner, #feedback-footer {
background-color:#0078D7;
color:white;
width:100%;
}

#feedback-banner td, #feedback-footer td {
border:0;
font-size:larger;
padding:10px;
}

#feedbacksection-v5 {
font-family:Segoe UI;
border:5px solid #0078D7;
border-collapse:collapse;
}

#feedbackdetails-table, #feedbackanalysis-table, #feedbacklinks-table {
font-family:Calibri Light;
background-color:#f5f5f5;
}

                                                
        This Bug was created from feedback triage by Eliot Graff
    

Report Details
                        Feedback Details
        Description
    
                Title
        yellowdig.com

    
                Description
        Modal dialog doesn't take input for login. Cannot input email address or password. Can't get focus in input fields. Only the LOGIN button works, which doesn't help without the sign-in data.

    
                Area Path
        UIF\Microsoft Edge\Website issues
    
                [Feedback Hub](../6835637/) with any questions or feedback you have.

[END AUTOBUG CONTENT]

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Steven K.”

    • Hi Kozyantin,

      Can you provide a simplified repro for this?

      Appreciate the help,

      Steve

    • Hi Steven,

      Sure, here is the repro: https://codepen.io/DmitriyKozyatinskiy/pen/JOQorL
      Also, this issue was originally called "pointer-events: none does not affect iframes in Edge v16", but it seems that parser had eaten everything before “:”

      Best regards,
      Dmitriy

    • Microsoft Edge Team

      Changed Assigned To to “wptcomptri@microsoft.com”

      Changed Assigned To to “Christian F.”

      Changed Assigned To from “Christian F.” to “Andrew B.”

      Changed Status to “Confirmed”

      Changed Assigned To from “Andrew B.” to “Christian F.”

      Changed Steps to Reproduce

      Changed Steps to Reproduce

      Changed Title from “none` does not affect iframes in Edge v16” to “none" does not affect iframes in Edge v16”

      Changed Status from “Confirmed” to “In code review”

      Changed Status from “In code review” to “Fixed”

      Changed Title from “none" does not affect iframes in Edge v16” to “Login dialog does not take any input on yellowdig.com ("pointer-events: none" does not affect iframes)”

      Changed Assigned To to “James M.”

    • Hello,

      Thank you for providing this information about the issue. We are pleased to report this feature is fixed in Edge and will be available in an upcoming insider build.

      Best Wishes,
      The MS Edge Team

    You need to sign in to your Microsoft account to add a comment.

    Sign in