Setting innerHTML on defs tags has no effect

Won’t fix Issue #15067283

Details

Author
Jason C.
Created
Dec 12, 2017
Privacy
This issue is public.
Found in
  • Microsoft Edge
  • Internet Explorer
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Sample Plunker:
https://plnkr.co/edit/JZEnJdcRqXpCIKoA9VMZ?p=preview
On Chrome, Firefox and Opera, clicking on “toggle” changes the background of the rectangle (from red to blue-striped). However, on IE 11 and Edge, the red background changes to solid black, as the pattern ISN’T inserted into the defs tag.

Version:
Windows 10 Enterprise, 64-bit
IE 11.0.10240.17146
Edge 20.10240.17146.0

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Steven K.”

  • Hi Jason,

    I tested this on 16299.64 and the toggle is working.  It looks like this have been fixed.

    Will you provide the extended version of Windows 10 you are using?  Win  S and type “winver” and hit enter?

    Thank you,

    Steve

  • Microsoft Edge Team

    Changed Assigned To to “travil”

  • I’m currently using version 10240.

  • Microsoft Edge Team

    Changed Status to “Fixed”

  • Hi Jason,

    This has been indeed been fixed in the latest build.  We typically only merge back security related issues to previous Windows 10 releases.

    Thank you for the submission,

    The MS Edge Team

  • Changed Status from “Fixed”

  • I have just checked in version 11.112.17134.0, and it is NOT fixed. Please check in Chrome to see the expected behavior (toggling should show blue stripes, NOT a black background).

  • Hi Jason,

    I just re-read the posts and realized that I was not very clear about patches to previous releases and to Internet Explorer.  This issue is publicly available for Edge since around release 16299.64.

    We are not presently working on feature bugs in Internet Explorer outside of security-related issues.

    Alternatively, if you have a premier support contract, you can visit https://premier.microsoft.com and open a support incident and work with an engineer to address this issue.

    Best regards,
    Steve

  • Microsoft Edge Team

    Changed Assigned To to “Steven K.”

    Changed Status to “Won’t fix”

You need to sign in to your Microsoft account to add a comment.

Sign in