Cannot open F12 Developer Tools

Fixed Issue #15458103


Marco C.
Jan 14, 2018
This issue is public.
Found in
  • Microsoft Edge
Found in build #
Reported by 3 people

Sign in to watch or report this issue.

Steps to reproduce

I have a new PC with Windows 10 (updated to build 17063). I cannot open / load the Developer Tools. See the screenshot.
I have already tried with restarts and different websites.


Comments and activity

  • As you can see from the screenshot the developer tools UI is not fully loaded and it is completely unresponsive (only the developer tools UI is unresponsive, the browser is not).

  • I have also tried to reinstall Edge as described here but nothing changes: the tools are broken.

  • Microsoft Edge Team

    Changed Assigned To to “James M.”

  • Hello,

    Thank you for providing this information about the issue. After thorough testing, we are unable to reproduce this problem in Edge 17063.

    Please let us know what happens when you click the (1) expand down icon (2) show console icon (3) undock icon. These items are identified in our attached file "public-15458103.png".

    Best Wishes,
    The MS Edge Team

  • Absolutely nothing happens when I click those icons. Then I have also tried with the other icons (like X) and nothing happens…

  • Can I do anything in order to help you reproduce the issue? For example, are there any logs that I can send to you? The (new) PC is an ASUS F541UV-GQ669T. The first time that I have opened the F12 tools I was surfing a website that uses service workers:

  • Hello,

    Thank you for providing more information about the issue. Please try these general troubleshooting steps to ensure you have the best Edge experience:

    Best Wishes,
    The MS Edge Team

  • It’s a new, clean installation of Windows 10 and I’ve already tried to completely reinstall Windows… but nothing has changed. Please provide more specific support.

  • Are there any updates on this? I have tested on the new build 17074 and the problem is still there. Are there any logs that you can investigate in order to find the cause of this?

  • Hello,

    Thank you for always providing new information about the issue. We are still unable to repro this problem in our new builds (e.g. 17063 and 170074). Sometimes browser extensions cause these kind of unexplained problems, so please try disabling all browser extensions and restarting Edge to see if this fixes the problem.

    Best Wishes,
    The MS Edge Team

  • It’s a new Windows installation… so there isn’t any Edge extension installed. I have also checked in the Edge settings -> extensions and the list is empty.

  • I have the same problem, F12 shows only a blank window regardless of the web page

  • I have added a snapshot where Edge fails to show developer tool on this very web page

  • Hello,

    Thank you for these diligent efforts. Can you please use the Feedback Hub to collect more information?

    1. Open the Feedback Hub app on your device 
    2. Click on the “Feedback” tab 
    3. Click on the " Add new feedback" button 
    4. Click "Problem", fill in the title/details and select “Microsoft Edge” as the category and the appropriate sub-category 
    5. Under "Recreate the problem", press “Start capture” 
    6. Once the capture has started, run through the steps required to reproduce your issue 
    7. Click “Stop capture” back in the Feedback Hub app 
    8. Press “Submit” 

    This will provide us with a trace we can use to debug the issue further. Once you’ve submitted this, please paste a link to the newly created Feedback Hub issue in this bug so that we can link the two together and continue to investigate.

    Best Wishes,
    The MS Edge Team

  • I have added debugging information via the Feedback Hub.

  • I have added debugging information via the Feedback Hub:

  • Microsoft Edge Team

    Changed Assigned To to “edgedevtoolstri”

    Changed Status to “Fixed”

  • Hello,

    Thank you for providing this information about the issue. We have confirmed the problem, and are considering a solution for a future build of Edge. We are presently tracking this issue as a duplicate of an existing internal bug report. We look forward to additional feedback you may have on how we can improve Microsoft Edge.

    Best Wishes,
    The MS Edge Team

  • Works for me now with build 17120.

You need to sign in to your Microsoft account to add a comment.

Sign in