MicroSoft Edge does not recognise <IMG style="height: 20%" SRC="example.jpg">

Issue #15995278 • Assigned to Travis L.

Details

Author
Nicholas S.
Created
Feb 17, 2018
Privacy
This issue is public.
Found in
  • Microsoft Edge
  • Internet Explorer
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

MicroSoft Edge does not recognise the following HTML code :

<IMG style="height: 20%" SRC="example.jpg">

This code renders perfectly correctly without any problem on Google Chrome and on Android. Why does it not do so on Edge ?

I use this attribute to reduce an image to the size of an icon when I am coding a menu of images . I use one of the images in a referenced folder as a simple icon, to illustrate a typical example of the contents of the referenced folder in the menu itself .

In Google Chrome and Android, it simply reduces the photo height to 20% of the original, whereas in MicroSoft Edge only, it displays the image in full size. That means that my website is compatible with Android and Google Chrome - the two dominant web browsers - but not in MicroSoft Edge. MicroSoft may have reasons for not supporting this feature, but consideration needs to be given that these days there are probably more cellphone devices which are used to access websites in the public arena (as opposed to the corporate arena) than Windows based devices.

I have always tried to be loyal to MicroSoft products but when they are not compatible with similar market-leading products, then it tests my loyalty.

Please fix this problem.

Thanks.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “James M.”

    • Hello,

      Thank you for providing this information about the issue. We are unable to reproduce this problem in Edge. Please test this behavior in our latest public stable build 16299.

      Best Wishes,
      The MS Edge Team

    • Microsoft Edge Team

      Changed Status to “Not reproducible”

    • I have tried this on the latest version of Microsoft Edge 42.17134.1.0 with Microsoft EdgeHTML 17.17134, and it definitely does not work. I have also tried the same thing on third party computers with the same result.

      Here is an example of the code which works perfectly on Android and on Google Chrome :

      If you look at the website concerned, you wilkl see exactly what I mean : www.shermans.uk

      If you then try the same thing of Chrome, you will see it presents properly.

      Please can you explain why people using Android and Chrome have no problems but only those using Edge do ?

      Thank you.

    • Changed Status from “Not reproducible”

    • I have tried this on the latest version of Microsoft Edge 42.17134.1.0 with Microsoft EdgeHTML 17.17134, and it definitely does not work. I have also tried the same thing on third party computers with the same result.

      Here is an example of the code which works perfectly on Android and on Google Chrome :

      If you look at the website concerned, you wilkl see exactly what I mean : www.shermans.uk

      If you then try the same thing of Chrome, you will see it presents properly.

      Please can you explain why people using Android and Chrome have no problems but only those using Edge do ?

      Thank you.

    • Microsoft Edge Team

      Changed Assigned To to “Steven K.”

    • Hi Nicholas,

      I loaded you website and was able to reproduce the issue in 17134.167 and in a recent RS5 development build.  Appreciate the follow-up on this.  We will investigate this.

      Nice photos by the way.  :)

      Steve

    • Microsoft Edge Team

      Changed Assigned To to “Travis L.”

    • Thanks but that is not much help as I do not want to have to change all my coding to Markdown just because the code does not work in Edge whereas it does in most other browsers. It is too much of a problem, and it would be much easier just to add a line onto my website to say that it should not be read in Edge but only in Chrome or some other browser. However, I doubt if Microsoft would like that as a solution, anymore than I would. I believe in TQM - getting it right first time rather than looking for work-arounds.

      Thanks all the same for the suggestion; I appreciate it was well meant.

    • Has there been any news on the investigation yet ? Thanks.

    • I’ll found the same:
      ist rendering full size.

    • btw. width is working. change height to width is a workaround.
      (I cant paste code in here?)

    You need to sign in to your Microsoft account to add a comment.

    Sign in