Edge Screen Capture API. I got MediaStreamError(abortError)

Fixed Issue #17357055

Details

Author
kenji t.
Created
May 3, 2018
Privacy
This issue is public.
Reports
Reported by 5 people

Sign in to watch or report this issue.

Steps to reproduce

I made a sample page of Edge’s Screen Capture API and tried it, but in my environment a MediaStreamError (abort) error occurs.
It is said that it worked in friends’ environment when friends tried it.
How can I solve this problem?
https://youtu.be/2-1l7QfPkXo

Attachments

1 attachment

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Steven K.”

    Changed Assigned To to “Arvind M.”

    Changed Assigned To to “Gurpreet V.”

    Changed Status to “Confirmed”

    Changed Status from “Confirmed”

  • I’m also running into this issue. Any updates or news on this? :)

  • First and foremost, it would be great if we could get a confirmation on whether this is an issue in the way me and Kenji are invoking the method, or if it’s a bug in the Edge implementation. Given that the status has changed to AND from "Confirmed", what is the current status on this?

  • For reference, I’m using the following when trying to invoke the method:

    navigator.getDisplayMedia({ video: true })
      .then(console.log)
      .catch(console.error);
    

    In addition to the, I’ve tried the following:

    • Not passing any constraints,
    • Trying on different domains to ensure it’s not a certificate issue,
    • Tried on 3 different computers running Windows 10 with all updates installed (EdgeHTML 17.17134), and
    • Trying the example outlined in the specification.

    In all cases, I get an AbortError:

    [object MediaStreamError]: {constraintName: null, message: null, name: "AbortError"}
    
  • Microsoft Edge Team

    Changed Assigned To to “comptriage”

  • I’ve gained access to another computer, on which it works fine, while I can still reproduce the issue on the original laptop (despite it being up to date).

    The computer on which it does not work is a low-end laptop, and I’m starting to wonder if that has anything to do with it? 2GB Ram, Intel Celeron CPU N3060 @ 1.60GHz 1.60 GHz. It’s up-to-date (Version 1803, OS Build 17134.228), and so is Edge (42.17134.1.0 and HTML 17.17134). It’s running the 64-bit version of Windows, and I assume Edge is 64-bit as well. The only difference I can tell from the two computers is that the one where it does not work has “ServiceUI 13” in the userAgent string.

    Does this clarify anything? I wonder if this is a wide-spread issue, or if it only affects certain computer models/makes. Since the version of Edge is the same in both cases, I don’t know how one would be able to detect one or the other wihtout actually initiating screensharing. It would be of significant value to me to learn more about the root of this issue, as it is currently blocking a major feature.

  • I get the same problem as Wilhelm on my wife’s laptop (an almost unused computer with latest Edge). The dialog to allow streaming appears once and then fails. Any attempts after that fails. Streaming is allowed for the site if I check site settings but it fails.

    On my developer PC with the same version of Edge it works - always. There seems to be some kind of dependency on some secret library that needs to be installed but is not installed on a plain vanilla PC.

    Could you investigate this further?

    Kind regards
    Tomas Nielsen

  • getDisplayMedia’s underlying Screen Capture APIs require Windows 10 Pro or Enterprise. See the “Note” from https://docs.microsoft.com/en-us/windows/uwp/audio-video-camera/screen-capture

  • Microsoft Edge Team

    Changed Status to “Fixed”

  • This does not at all match what’s announced in the Edge 17 release notes and the platform status.
    Can you update those docs.
    Thanks
    Haian

  • Could you double check that this is not an unintended requirement on Pro or Enterprise?

    In the docs it simply says it is supported on Edge on the desktop (no fine print or anything):
    https://developer.microsoft.com/en-us/microsoft-edge/platform/status/screencapture/

    I can understand that there are differences in the operating system depending on what version you have bought. But that should not affect the Edge browser - that is separate from the operating system.

    Kind regards
    Tomas Nielsen

  • As noted in the status tool, “This feature works only on Window 10 Pro and Enterprise editions.”

    This unfortunate limitation derives from a limitation in the UWP Windows.Graphics.Capture APIs that Edge uses.

    https://docs.microsoft.com/en-us/windows/uwp/audio-video-camera/screen-capture

You need to sign in to your Microsoft account to add a comment.

Sign in