EDGE crashes soon after it is launched

Not reproducible Issue #17952042

Details

Author
undefined u.
Created
Jun 19, 2018
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

I’m using,
◦Selenium 3.12.0
◦Java binding
◦Windows 10 (build 15063.1029)
◦EDGE driver (Version: 4.15063 | Edge version supported: 15.15063 )

Here is my code to open the browser,
import org.openqa.selenium.edge.EdgeDriver;
System.setProperty(“webdriver.edge.driver", C://mE//Selenium//Installation//Drivers//Edge//v15063//MicrosoftWebDriver.exe”);
WebDriver driver = new EdgeDriver();

The browser (EDGE) opens for a sec and then crashes immediately. Here is the error (unknown),

Exception in thread “main” org.openqa.selenium.WebDriverException: Unable to parse remote response: Unknown error
Build info: version: '3.11.0’, revision: 'e59cfb3’, time: ‘2018-03-11T20:33:08.638Z’
os.name: 'Windows 10’, os.version: '10.0’, java.version: ‘10.0.1’
Driver info: driver.version: EdgeDriver
at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:111)
at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:73)
at org.openqa.selenium.remote.HttpCommandExecutor.execute(HttpCommandExecutor.java:136)
at org.openqa.selenium.remote.service.DriverCommandExecutor.execute(DriverCommandExecutor.java:83)
at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:545)
at org.openqa.selenium.remote.RemoteWebDriver.startSession(RemoteWebDriver.java:209)
at org.openqa.selenium.remote.RemoteWebDriver.(RemoteWebDriver.java:132)
at org.openqa.selenium.edge.EdgeDriver.(EdgeDriver.java:141)
at org.openqa.selenium.edge.EdgeDriver.(EdgeDriver.java:96)
at projectOne.classOne.main(classOne.java:66)

This only happens with EDGE. Other browsers (IE, Chrome & FireFox) are launching just fine.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Steven K.”

    • Hi,

      I am wondering if your version of the Microsoft WebDriver.exe is the correct version for your machine.

      Will you double click the exe in "C://mE//Selenium//Installation//Drivers//Edge//v15063//MicrosoftWebDriver.exe”?  If it runs then it is the proper version.  If it does not you will need to download the 15063 version.

      https://developer.microsoft.com/en-us/microsoft-edge/tools/webdriver/

      Steve

    • Microsoft Edge Team

      Changed Status to “Not reproducible”

    • Sorry, reproducible.

    • Hi!

      Thank you for contacting us! Using the attached code snippet and using the Windows Feature on Demand version of MicrosoftWebDriver, I have no problems launching Microsoft Edge. Please ensure you are using the most recent version of the browser and driver when performing automation to avoid any issues.

      Java Selenium code: https://gist.github.com/wootiml33t/e9e94f382fc07486daabe3c098e5caa2

      To install the Windows Feature on Demand version of MicrosoftWebDriver, run the following command in an elevated command prompt: 

      DISM.exe /Online /Add-Capability /CapabilityName:Microsoft.WebDriver~~~~0.0.1.0

      The default installation directory for this version of the driver is: 

      C:
      Windows
      SysWOW64
      MicrosoftWebDriver.exe

      Thanks,

      Zach

    You need to sign in to your Microsoft account to add a comment.

    Sign in