Fetch Api post not working in latest version of edge

Issue #18775440 • Assigned to Brandon M.

Details

Author
Dan S.
Created
Aug 23, 2018
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 7 people

Sign in to watch or report this issue.

Steps to reproduce

After updating Edge recently to Microsoft Edge 42.17134.1.0 Microsoft EdgeHTML 17.17134 our login Fetch post method no longer works on it.

There is no error given, no crash, and after extensive debugging it simply appears that the call is never even made. Edge just skips over the fetch() call entirely.

I created a JsFiddle demonstrating the issue here http://jsfiddle.net/dnq2osoy/2218/, with fake credentials of course.

It doesn’t seem to be a Fetch issue because I tried jQuery and $post and that behaves exactly the same. On every other browser (including Edge v41.x and even IE) it returns the appropriate error of bad username/password.

Thanks, looking forward to feedback.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Brandon M.”

    • Hello, has anyone been able to take a look at this?

    • I faced this same issue. Working with a brilliant engineer at my office and we figured out that the post on fetch was failing because Edge wants the body to be a string. So I just added a toString() to the end of the body portion of the post. The two headers are needed as well so this will work on other browsers like chrome.

      Code snippet:

      return fetch(URL, {
            method: 'POST',
            credentials: 'same-origin',
            headers: {
              'Content-Type': 'application/x-www-form-urlencoded; charset=UTF-8',
              'Upgrade-Insecure-Requests': 1
            },
            body: urlParams({
              username: this.state.username,
              password: this.state.password,
              _csrf: token
            }).toString()
          })
      
    • Has this been addressed yet? I found that it still doesn’t work when calling the API from an extension. Should a new issue be raised?

    • HI, I have the same issue also using the same version of edge. Basically no POST fetch is sent successfully. Could you confirm and tell us when it can be fixed?

    • So far no response from Microsoft. Come on guys, is Edge dead now? Three years have past since its first release and there are still major bugs.

    You need to sign in to your Microsoft account to add a comment.

    Sign in